Appium codeception iOS simulator error: could not find any webviews yet refreshing/retrying

    down vote


When I try to launch safari on iPad simulator and do $I->amOnPage(“”). Safari browser is launched but is stuck at I see in appium logs this warning “could not find any webviews yet refreshing/retrying” and then nothing happens.

I use Appium 1.4.8, OS X 10.10 Yosemite, codeception 2.1.2, XCode
6.4. I have no idea what I am doing wrong. I looked up online and some
said I should be running ios_webkit_proxy_launcher. I tried running that
on 27753 with -c and simulator UDID -d options and retried my test.
Still no change. ios proxy starts up but has no logs whatsoever. These
are the desired capabilities I am using :

- WebDriver
url: ‘
connection_timeout: 500
request_timeout: 500
browser: ‘safari’
port: 4723
browserName: ‘safari’
platformVersion: “8.4”
platformName: “iOS”
deviceName: ‘iPad Retina’
connection_timeout: 500
request_timeout: 500

Any ideas? Thanks.

However I can get things to work fine with PHPUnit! Dont know whats going on with codeception.