Appium Desktop can't sign an Android app on Windows


I’m trying to run Appium Desktop on Windows with a real Android device but the app can never be installed because of this error:

[MJSONWP] Encountered internal error running command: Error: Error executing adbExec. Original error: 'Command ''C:\\Users\\Dustin Altermann\\AppData\\Local\\Android\\sdk\\platform-tools\\adb.exe' -P 5037 -s 9885a6505a594d4445 shell pm install -r /data/local/tmp/70ba3c7a7883704d9863307fe101dca4.apk' exited with code 1'; Stderr: 'Failure [INSTALL_PARSE_FAILED_NO_CERTIFICATES: Failed to collect certificates from /data/app/vmdl404765495.tmp/base.apk: Attempt to get length of null array]'; Code: '1'

So I already tried a ton of things to solve this as the error message is pretty clear and says that appium was somehow not able to resign the app in order to install it. In comparison I resigned an app using selendroid standalone and fed that app into appium and it instantly worked fine.

Then I played around with my .android/debug.keystore file but sort of blindly as i don’t really know what the problem is in particular. Also using all the desired capabilities related to the keystore didn’t help…

At this point I really have no clue as the appium console doesn’t even contain the step where it should sign the app (and no I don’t have the “noSign” capability set) … can anybody help?


when i run on Eclipse getting Error:Failure [INSTALL_PARSE_FAILED_NO_CERTIFICATES]

Even i tried with “nosign” Capability nd many other solutions still gets same issue