Appium Doctor Doesn't Run and Displays Could Not Detect Mac OS X Version Error

My appium doctor command doesn’t run. It has an error. Can anyone tell me how to fix appium doctor?

If I go to the Appium\bin Folder and type appium-doctor, it will say command not found.
But in the folder I see the appium-doctor.js file though.

If I click from the Appium GUI app then I see this error below.
unknown20C9D0E03E3B:~ mac$ ‘/usr/local/bin/node’ ‘/Applications/’
Running iOS Checks
:heavy_multiplication_x: Could not detect Mac OS X Version
Appium-Doctor detected problems. Please fix and rerun Appium-Doctor.

I’m using El Capitan OS and appium version 1.4.11.
I installed appium by

  1. git clone
  2. ./ --ios --real-safari --code-sign ‘’ --profile ‘’

Could you try ‘./appium-doctor’ or ‘./appium-doctor.js’? That’s ‘dot slash appium-doctor’, and try it with the .js if that doesn’t work.

Thank you so much for your help. You helped me solved it.
./appium-doctor.js worked.
I had to install some Xcode command line tools when appium doctor ran.
This may solve another problem error I was seeing too for another issue.

Glad that worked for you.

Hi there what command did you run?

@seleniumappiumnewbie what command did you use? I am seeing the same issue.
how did you run it?