Appium-doctor Results in Android Could NOT be Found in sdk


I am new to appium. I would like to use Appium on Windows 10 to test my Android app. So, I am following the directions on “”. I successfully ran the following:

npm install -g appium
npm install -g appium-doctor

However, running “appium-doctor --android” results in the following error:
android could NOT be found in C:\Users\CharlesTeague\AppData\Local\Android\Sdk!

What should I do to resolve the above error.

Thanks in advanced for your help.
Charlie Teague

it is not clear in docs but follow link ->

check Java and install Android SDK by downloading and installing Android Studio first.

@Aleksei Thank you for the help. I already had installed Android Studio. I have version 4.The SDK Manager in this version has “Android SDK Tools” marked as Obsolete, so I had not installed them. So, to resolve this issue I did two things:

  1. Install the “Android SDK Tools” marked as Obsolete
  2. Add “C:\Users\CharlesTeague\AppData\Local\Android\Sdk\tools\bin” to my Path Environment Variables.

Now, the error message about not finding Android in the sdk no longer appears.


Thanks a lot Charles. I did only the first step and it solved my problem :+1:

1 Like

I reinstalled Android Studio but I’m getting the same error

Same here,

By installing the “Android SDK Tools” that was marked as obsolete, Appium-doctor recognise and found the SDK.

thanks guys!