Appium doesn't boot the simulator, if the simulator is already running


#1

Hello,

I am seeing weird issue, where I try to invoke my app using Appium Desktop

Environment:-
Appium Desktop: 1.6.2
Appium Server : 1.8.1
Xcode: 9.4.1
Mac OS Version : 10.13.6

Capabilities:
{
“platformName”: “iOS”,
“platformVersion”: “10.3”,
“deviceName”: “iPhone 6”,
“automationName”: “XCUITest”,
“locationServicesEnabled”: true,
“autoAcceptAlerts”: true,
“app”: “/Users/kpalanisamy/Downloads/test.app”,
“noReset”: false
}

Issue:
First time, when i start session using Appium Desktop(with simulator closed) ; Simulator gets booted, installed the app and WDA. Opens up the app in the specified iOS Simulator

But, now i am starting the session again using the same appium Desktop(with simulator already running); Simulator doesn’t get booted, not installing the app and also WDA. Doesn’t open up the app in the ios Simulator.

Suprisingly, the Appium Inspector shows the app inovked ; but not the simulator.

Looks very weird! Was working before;

Workarounds:
Tried with new OS Version, Xcode Version(10) and also Appium version(1.8.2);
Tried with running appium in the background with CLI

Note:
Basically, it needs simulator to be closed everytime to bring an fresh simulator

Looks Fishy here in the Log :_eb> ug] [XCUITest] Killing running processes ‘xcodebuild.*3692D94D-2477-4056-9482-2E95C1749B23, 3692D94D-2477-4056-9482-2E95C1749B23.*XCTRunner’ for the device 3692D94D-2477-4056-9482-2E95C1749B23…[info] [Xcode] ** BUILD INTERRUPTED _

Kindly, help me out with this issueAppiumIssueLog.txt (31.0 KB)