Appium doesnt boots the simulator, and installs the WDA, if the iOS simulator is already running


#1

Hello,

I am seeing weird issue, where I try to invoke my app using Appium Desktop

Environment:-

  1. Appium Desktop: 1.6.2
  2. Appium Server : 1.8.1
  3. Xcode: 9.4.1
  4. Mac OS Version : 10.13.6

Capabilities:

{
“platformName”: “iOS”,
“platformVersion”: “10.3”,
“deviceName”: “iPhone 6”,
“automationName”: “XCUITest”,
“locationServicesEnabled”: true,
“autoAcceptAlerts”: true,
“app”: “/Users/kpalanisamy/Downloads/test.app”,
“noReset”: false
}

Issue:
first time, when i start session using Appium Desktop(with simulator closed) ; Simulator gets booted, installed the app and WDA. Opens up the app in the specified iOS Simulator

But, now i am starting the session again using the same appium Desktop(with simulator already running); Simulator doesn’t get booted, not installing the app and also WDA. Doesn’t open up the app in the ios Simulator.

Suprisingly, the Appium Inspector shows the app inovked ; but not the simulator.

Looks very weird! Was working before;

Workarounds:
Tried with new OS Version, Xcode Version(10) and also Appium version(1.8.2);
Tried with running appium in the background with CLI

Note:
Basically, it needs simulator to be closed everytime to bring an fresh simulator

Kindly, help me out with this issueAppiumIssueLog.txt (31.0 KB)