Appium GUI 1.52 Inspector is not recognising items on screen (Not Clickable)

I had installed Appium GUI 1.5.2 and configured in iOS settings capabilities to launch Safari with iPad device connected to it.
ios_webkit_debugger is installed and running.

When launching the inspector, it opens and the screen is reflected… but nothing is happening when clicking on items of the screen!
(Can’t get xpath\id… locators)

I found in some forums a recomendation to work with lower version, so I tried installing Appium 1.4.13; Then I realized that SafariLauncher is not part of that installation and need to install it manually.
I got the SafariLauncher from GIT, opened the project by XCode and ran it on my iPad and got Build Successful.
When launching it from device itself it opens and load as default page, but when trying to launch it from Appium inspector I’m getting:

error: Failed to start an Appium session, err was: Error: ENOENT, stat '/Applications/Appium'  
info: [debug] Using local .zip from command line: /Applications/Appium  
info: [debug] Copying local zip to tmp dir  
info: [debug] Got configuration error, not starting session  
info: [debug] Cleaning up appium session  
info: [debug] Error: ENOENT, stat '/Applications/Appium'  
    at Error (native)  
info: [debug] Responding to client with error: {"status":33,"value":{"message":"A new session could not be created. (Original error: ENOENT, stat '/Applications/Appium')","errno":-2,"code":"ENOENT","path":"/Applications/Appium","origValue":"ENOENT, stat '/Applications/Appium'"},"sessionId":null}  
info: <-- POST /wd/hub/session 500 12.924 ms - 519  

Please advice…
I’m new with Appium and I had been stragelling for a long time to make things work

Thanks in advance.

BTW I managed.
If anyone is facing the same it can be done with these steps:

  1. Creating the missing folder SafariLauncher manually:

info: [debug] Error: ENOENT, stat ‘/Applications/Appium’
at Error (native)

This folder should contain a zip file ( which contains the only

  1. If you still get errors like: SafariLauncher icon already exist…
    Change your capabilities to use the from “App Path” and don’t use “Use Mobile Safari”.

This should do the trick.