Appium Inspector fails to run because XCode build fails with error 70

The Problem

I’m trying to set up Appium 2 for iOS testing by running Appium Inspector.
However, I’m running into an issue where whenever I try to initiate a session, it fails to run because XCode fails to build webdriveragent.


Appium: 2.0.0-beta.44
Appium Inspector: 2022.11.1
MacOS Monterey: 12.5.1
XCode: 14.1
Simulator: iOS 14.5


GIST: appium with xcode logs


I have an iPhone 12 Pro Simulator running iOS 14.5.
The simulator is running fine, and whenever I build the webdriveragent project directly from XCode, it works.
However the build command that appium inspector calls seems to fail every single time.

Running the same command directly in the commandline ends up with the same error.

Capabilities need some adjustment is all. The example at the top of this page shows the capabilities you need to run a simulator:

1 Like


I ran it with exactly what’s in the article but I still get the same error.

Hard to say what’s happened without current log.

1 Like

I have no idea why. But this seemed to fix it.

In “Applications/”

  MacOSX.sdk -> MacOSX12.5.1.sdk (the same as my current Mac OSX version)

Apparently xcodebuild was failing due to this descrepency in os version but didn’t output anything.
Which is double weird because xcode UI had no issues.

But since fixing this portion, it seems to be running fine.

1 Like

Wow, thanks for posting the answer

1 Like