Appium Inspector: iOS .app file not installing in the iPhone simulator

Lately I have migrated to Appium 2.x.x…The migration was bit hectic but luckily I setup everything.

I am now stuck at a situation, where I want to get the locators for the iOS application through Appium Inspector. The appium inspector fails to install the .ipa file if I start the session from it desired capabilities, however the app get installed in simulator when I run it through my automation script.

Any chance/idea why I am not seeing the app installed in it? My iphone simulator looks like this as for now,

Danke Schön!

I have also tried attaching to the session, but seems like the session-id is not appearing in the tab.

.ipa = REAL phone
.app = simulator

ask needed build from developers or get access to iOS code and generate it yourself

I am using .app for simulator…
The issue is, that the .ipa file is not installing the app when I try to run the session from the Appium inspector.

iOS .ipa file not installing in the iPhone simulator - this is your question :face_with_monocle:
if you use .app instead
1 enable debug logs with Appium server
2 read what exactly command fails
3 write it here

1 Like

Oh yes, I can change it to .app :slight_smile:

I did what you said but even then all I can see is that the appium tries to connect and receive the capabilities I have define yet the .app file is unable to get installed.

Aitah @Aleksei but I have resolved the problem on my own :slight_smile:
Good day!

Im facing the error 500 I gave the path .ipa file it showing session not created