Appium: Inspector locating issue in Xamarin apps


I am an automation tester and i use selenium for scripting.
Toos used:

Appium Desktop version: 1.7.2
Xamarin forms: 7.3.2
MAC machine version: Sierra
Xcode 9.2

The IOS app developed using Xamarin do not through any “Accessibility IDs” when inspected with Appium.
Even Android app has the same issue, but as it has the “Class name” and “text” locators available, i am using them as a work around. [e.g… //android.widget.Button[@text=‘LOG IN’])

I tried using Style IDs everywhere, and also tried using Automation IDs, but in IOS app, the locators are not appearing.
ISSUE1: In IOS, sometimes it appears in the Hamburger Menu, but they are not the IDs which i provided.
ISSUE2: In Android, IDs appear but when they are used in scripting, they do not show a response.

This app used to work properly till the use of previous Xamarin forms version.

Recently Xamarin forms where updated, including the SDKs and IDE. I am not sure if this is because of updating the tools.

ISSUE3: In screens where ListView and Grouping is done, i am unable to capture unique objects within the group. Please help in how to tackle this situation.

Mobile Application Tester (Automation)