Appium Inspector not able to Recognize a Screen

Hi Team,
I am using Appium latest version 1.6.2 / Server v1.8.1 / Port 4723
It was working like a cream so far for my application.
Recently I landed onto a Screen where Appium Inspector is not able to recognize the element itself it is not taking the Screenshot in first go, later after 10 -15 tries if it takes the screenshot then also it doesn’t returns the ID.

Then I tried getting the ID from uiAutomaterViewer I was able to get the ID for the Screen
But while executing the test cases which the Specific ID it is not let me operate.
Strange part is : The Screen only contains some text message & one Button.
The Appium even doesnt allow be to do simple BackPress operation once we land on that Screen

The Eclipse LOGs:

rg.openqa.selenium.remote.UnreachableBrowserException: Error communicating with the remote browser. It may have died.
Build info: version: ‘2.44.0’, revision: ‘76d78cf323ce037c5f92db6c1bba601c2ac43ad8’, time: ‘2014-10-23 13:11:40’
System info: host: ‘ATLAP125’, ip: ‘’, ‘Windows 10’, os.arch: ‘amd64’, os.version: ‘10.0’, java.version: ‘10.0.1’
Driver info: driver.version: AppiumDriver
at org.openqa.selenium.remote.RemoteWebDriver.execute(
at io.appium.java_client.AppiumDriver.execute(
at io.appium.java_client.AppiumDriver.execute(
at org.openqa.selenium.remote.RemoteWebDriver$RemoteNavigation.back(
at com.RestApiUtils.PackagePrivilagePreference.BackPressed(
at com.testcase.AdminBuyMoreTestCases.verifywithNoZIP(
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.base/java.lang.reflect.Method.invoke(Unknown Source)
at org.testng.internal.MethodInvocationHelper.invokeMethod(
at org.testng.internal.Invoker.invokeMethod(
at org.testng.internal.Invoker.invokeTestMethod(
at org.testng.internal.Invoker.invokeTestMethods(
at org.testng.internal.TestMethodWorker.invokeTestMethods(
at org.testng.TestRunner.privateRun(
at org.testng.SuiteRunner.runTest(
at org.testng.SuiteRunner.runSequentially(
at org.testng.SuiteRunner.privateRun(
at org.testng.SuiteRunnerWorker.runSuite(
at org.testng.TestNG.runSuitesSequentially(
at org.testng.TestNG.runSuitesLocally(
at org.testng.remote.RemoteTestNG.initAndRun(
at org.testng.remote.RemoteTestNG.main(
Caused by: org.apache.http.NoHttpResponseException: failed to respond
at org.apache.http.impl.conn.DefaultHttpResponseParser.parseHead(
at org.apache.http.impl.conn.DefaultHttpResponseParser.parseHead(
at org.apache.http.impl.DefaultBHttpClientConnection.receiveResponseHeader(
at org.apache.http.impl.conn.CPoolProxy.receiveResponseHeader(
at org.apache.http.protocol.HttpRequestExecutor.doReceiveResponse(
at org.apache.http.protocol.HttpRequestExecutor.execute(
at org.apache.http.impl.execchain.MainClientExec.execute(
at org.apache.http.impl.execchain.ProtocolExec.execute(
at org.apache.http.impl.execchain.RetryExec.execute(
at org.apache.http.impl.execchain.RedirectExec.execute(
at org.apache.http.impl.client.InternalHttpClient.doExecute(
at org.apache.http.impl.client.CloseableHttpClient.execute(
at org.apache.http.impl.client.CloseableHttpClient.execute(
at org.openqa.selenium.remote.HttpCommandExecutor.fallBackExecute(
at org.openqa.selenium.remote.HttpCommandExecutor.execute(
at org.openqa.selenium.remote.RemoteWebDriver.execute(
… 29 more

Please look into it.

Hi Tanya,

Is this exception thrown every time? It appears as though uiautomator2 closes / crashes in the middle of your run. Also, is this a webview part of the app? If so, then the chromedriver version might not match.

Hi Bennid

Yes, I get the Same exception every-time.
No its not a web-view its a simple Fragment Screen which fails every-time, I try to click on the View Order button.
Even same can not be recognized if I run the uiAutomator2 Inspector to get the Identity.
But I can get the identity from uiAutomator1.

Can you put the appium server logs up on gist and get the logcat from the phone as well? Might be a bug here that should be filed.

Appium.txt (9.5 KB)
It fails on Several Screen, One shown before other one in this log.
Eclipse.txt (4.5 KB)