Appium inspector not working properly after upgrading to Appium 1.4.13 and OS X El Capitan

Appium 1.4.13 (command line to run tests, GUI for Inspector)
Xcode 7.1
OS X El Capitan 10.11.1
iOS Version 9.1
iOS Simulator iPhone 6 and iPhone 5s (tried)

When I try to run automated tests on the iOS simulator after upgrading Appium to 1.4.13 and OS X to El Capitan, the Appium inspector does not work properly. I see one of several outcomes:

  1. The screenshot is displayed, but no elements are listed in the columns to the left of the screenshot (regardless of whether Show Disabled/Invisible are checked.) Sometimes I may get [UIAApplication], but that’s it. I also copied the XML tree to see if it contains anything beyond UIAApplication, but it does not.
  2. Inspector is in a constant state of refresh until the test fails.
  3. Clicking refresh button causes the inspector to refresh for a fraction of a second and then stop. On the rare occasion that the refresh button does work, it takes much longer than usual to refresh the screen.

Since the upgrades, I am having a 0% success rate using the inspector to locate element selectors.

Is anyone else having problems with the Appium inspections under the same or similar conditions?

I’ve same issue

@zcmgyu - I don’t think we’re having the same issue. I can launch the inspector, but it’s not showing me the elements that I see on the screen that is captured. It looks like you can’t launch the inspector at all.

I’ve seen the error that you’re seeing before, and it’s usually because I was trying to run the inspector before launching the Appium server. Could that be the cause of the issue you’re having?

Thanks for your comment. I’ll add a screenshot of the issue that I’m having so it’s more clear to everyone.

Hopefully this screenshot helps to clarify my issue. I’m only getting [UIAApplication] , and clicking on it does not expose the other elements on the screen, like buttons and text fields.

I am facing the same issue… Only 50% of the elements show up in the inspector. Hitting refresh takes forever and have to kill the inspector. Also seeing the same issue when taking screenshots, only half of total elements showing up.

1 Like

And this issue came after update to El Captain ? :confused:

I am still on yosemite… for me it came after latest appium update

@Julien_Blanc - It did for me, but I upgraded Appium around the same time that I upgraded my OS. (In hindsight, that was a bad idea.) @sahiltaneja29 mentioned having the same problem on Yosemite, so it sounds more likely that the issue is with the most recent Appium update.

I think i experience a similar problem as sahiltaneja29 but it seems to be a problem with XCode 7 in my case. see
Ios and Accessibility for details.

1 Like

I tried updating to Appium 1.4.14 while still on Xcode 7.1, and I had the same problem described in my first post.

Then I tried Appium 1.4.14 after upgrading to Xcode 7.1.1. The first time I ran a test, I was able to capture a screenshot and the full tree of elements as expected. When the test opened the next screen of the app, I clicked Refresh and it got stuck in refresh mode. Ever since then, when I try to run a test and use the inspector, clicking the Refresh button does nothing. The button sort of flashes as if it’s about to capture the screen and element data and then abruptly stops. This all happens in about a quarter to half a second.

I should also mention that the Appium inspector is working perfectly for my Android tests.

@rompic - Thanks for your comment. I read the thread that you linked to, and it seems like there are some similarities between the issues that we’re having. I’ll also try an older version of Xcode to verify, and then I’ll report back.

Hi chiwhitesox56,
I am facing the same issue with the same environment you mentioned. Did you get any solution for the same? Inspector is not launching with latest xcode 7.1.1 and appium 1.4.13.

Hi @amitajain,

I upgraded to Appium 1.4.16 (still on Xcode 7.1.1), and I’m seeing something a little different now. The Inspector actually does work now on screens that appear before the user logs into the app. Once the user logs in, the app is very slow to load. (It never finishes before timing out.) If I try to launch or refresh the Inspector at this point, I get the eternal spinner on the refresh button. (Maybe this is happening because the page isn’t fully loaded yet? I’m not sure.)

I’m not seeing the original issue where the Inspector loads incomplete data about what’s on the screen, so that’s good. I either see what I’m supposed to (before authentication) or nothing at all (after authentication).

I do not have these problems with my Android tests. Only iOS.

I was with this same problem and after spend some hours trying to upgrade (and downgrade) my applications (Xcode and Appium) I resolved this problem changing the iPhone Simulator scale to 100% (Window > Scale > 100%), and now it is working fine.

Now I am using

  • Xcode 7.3.1
  • Appium 1.4.16
  • iPhone Simulator 9.3
  • iOS Version 9.2
  • It is working with Appium 1.5.3 too!
1 Like