Appium Inspector throws error :Failed to connect to to server, Pls check that it is running

  1. I have Appium running on Windows 7.
  2. I started Appium Server, which contains path of app contact-Manager.apk.
  3. App is running on Android Emulator.
  4. Open Appium Inspector & click on Refresh button

Throws error “Failed to connect to server. Please check that it is running”. What is wrong with my configuration?

Note - Once I click on Ok button of pop up error, Appium server is getting stopped.

1 Like

Even I face the same problem while using the Appium Inspector and looking for the solution.
some fields are not detected with the properties like ID,name etc…

Ty the check the “Pre-Launch Appliciton” on General Settings. It works for me to fix the issue.

Hi Ethan, Pre-launch doesn’t work for me. Is there any other option to make Inspector work ?

I have the same issue. Does anyone have solution?

Hi Leonid, “Pre-Launch” works surprisingly now !! And the Appium inspector displays my app/device screen but I’m unable to take/see the html source :frowning:


I am also facing the same problem in my windows 8 system?
How to get the UI filed ID/Name/Xpath?
Please help me…


HI friends
please help…

Hi guys,

Please help me How to get the Inspector in appium.

And How to recognize the Hybrid app?


Hello guys,

I was also facing same problem.
But “pre-launch” option works for me.

I think inspector work same as Android default Uiautomator and it just show the current screen displays on device. So that’s why Application should be running on device.


I am facing the same problem. I tried pre-launch application, but appium stoped working.

Previous, I can’t have this issue, now I upgrade my appium to and I have this issue now. Anyone can help. thanks.

I am not sure it is bug or not supported in Windows 7 machine. When i tried in my Windows 7 machine it didnt work though. Then i surfed internet and many people were mentioning it is not supported in Windows 7 and works well in iMac.

Inroder to get object properties you can also try uiautomatorviewer, which is available in AndroidSDK\Tools\uiautomatorviewer.bat.

Let me know how did you accessed these objects in Windows 7 earlier? you were using inspector?

hi all,

I enabled the pre-launch from appium settings, but still i am getting the error which shown in shreeshot, im using appium
window 7
added apk of whatsapp, downloaded from android apk downloads.

any help please.

got the solution:
my apk location folder path having space, remove the space and retried, all works fine

Hi Kancharia,
My apk location path for app is D:\whatsApp.apk ,but still i am facing the issue for

It would be great if anyone provide solution for this issue.

To recognise if the app is hybrid, you can go to chrome://inspect/devices, and if the page is a webview, it will show you the device will inspect button next to it. If it is native, this page will be blank

I am facing same issue on Appium , Windows 10. How can i rectify it

1 Like

I am facing same issue on appium-desktop-Setup-1.6.3-ia32, please help me