Appium is not installing app: instruments crash on startup

If the app is already installed, I can run my tests fine, but if its not, i got the message that instruments crashed on startup and it fails.

here is part of the log

[debug] [Instruments] Attempting to launch instruments, this is try #4
[Instruments] Launching instruments
[debug] [Instruments] Attempting to run app on real device with UDID 'DEVICE UDID HERE'
[debug] [Instruments] Found Insruments-Without-Delay: /usr/local/lib/node_modules/appium/node_modules/appium-ios-driver/node_modules/appium-instruments/thirdparty/iwd7
[debug] [Instruments] Spawning instruments with command: '/Applications/ -t /Applications/ -D /var/folders/k0/s803_jl52hvggnvg9sbdbbf00000gn/T/appium-instruments/instrumentscli0.trace -w _<DEVICE UDID HERE>_ cheats.ipa -e UIASCRIPT "/Users/julia/Library/Application Support/appium/bootstrap/bootstrap-5a5c47a2bee114f6.js" -e UIARESULTSPATH /var/folders/k0/s803_jl52hvggnvg9sbdbbf00000gn/T/appium-instruments'
[debug] [Instruments] And extra without-delay env: {}
[debug] [Instruments] And launch timeouts (in ms): {"global":1000000}
[debug] [Instruments] [INST STDERR] Instruments Usage Error: Specified target process is invalid: cheats.ipa
[debug] [Instruments] [INST STDERR] instruments, version 7.3 (60134)
usage: instruments [-t template] [-D document] [-l timeLimit] [-i #] [-w device] [[-p pid] | [application [-e variable value] [argument ...]]]
[debug] [Instruments] Instruments exited with code 255
[Instruments] Error launching instruments: Instruments crashed on startup

Xcode version 7.3.1
Appium version 1.5.2
tried on real devices, ios 7.x and 9.x

OBS: One thing I notice is that even when the app is installed, i see the appium log message that app is not installed, will install. Apparently it doesn’t install, but the tests runs fine

Could it be that you need to supply the path to ‘cheats.ipa’?

its because I put it on same path I run the tests, just to exclude that kind of problem

when I run that command, it shows me this error:

Instruments Trace Error : Target failed to run: The operation couldn’t be completed. (FBSOpenApplicationErrorDomain error 4.) : Failed to launch process with bundle identifier 'cheats.ipa'

it looks like it is only trying to run the app, not install, what am I missing here? here is my capabilities:

platformName: 'iOS',
    versionNumber: '9.3',
    deviceName: get_device_name,
    app: APP_PATH,
    backendRetries: 1,
    nativeInstrumentsLib: false,
    launchTimeout: 1000000,
    waitForAppScript: "true",
    autoAcceptAlerts: true,
    newCommandTimeout: 12000,
    udid: get_udid

ok so googleing it i found this, updated appium and now it works… too bad it took me a workday to find this out it was an appium bug

ps: i could only update appium running the command to install it again (using npm)

last info: after the update, appium was installing but not launching, i fixed it adding --pre-launch tag to start appium