Appium is not responding while executing program

I have used the below code snippet to launch Amazon App in my android
phone and also started Appium server before I run the program. My
program is running with out any errors but test is not passed and Amazon app is not launched.

    File classpathRoot = new File(System.getProperty("user.dir"));
    File appDir = new File(classpathRoot, "/Apps/Amazon/");
    File app = new File(appDir, "");
    DesiredCapabilities capability = new DesiredCapabilities();
    capability.setCapability("deviceName", "Moto G (2nd Generation)");
    capability.setCapability("platformName", "Android");
    capability.setCapability("platformVersion", "5.0.2");
    capability.setCapability("app", app.getAbsolutePath());
    capability.setCapability("appPackage", "");
    capability.setCapability("appActivity", "");
    driver = new AndroidDriver(new URL(""), capability);

Below are my observations

Appium Server is not responding while executing the program and also I could not see any message in Appium Console
Please assist me on this

What happens if you try visiting in your browser?

I am giving my system ip address for appium server as well and updated the same in the script.
Even if appium server default ip address also did not help to launch

Did you try what I suggested in the last post? If Appium is running and set up correctly, you should be seeing a JSON response in your browser.

Hi, I have tried that also but no luck. Can you please help me to sort out this

Yes, Alex. I could see json messages as below in appium server when I started it

Launching Appium server with command: C:\Program Files (x86)\Appium\node.exe lib\server\main.js --address --port 4723 --no-reset --platform-name Android --platform-version 23 --automation-name Appium --log-no-color
warn: Appium support for versions of node < 0.12 has been deprecated and will be removed in a future version. Please upgrade!
info: Welcome to Appium v1.4.13 (REV c75d8adcb66a75818a542fe1891a34260c21f76a)
info: Appium REST http interface listener started on
info: [debug] Non-default server args: {“address”:“”,“noReset”:true,“logNoColors”:true,“platformName”:“Android”,“platformVersion”:“23”,“automationName”:“Appium”}
info: Console LogLevel: debug

But when I run my program in TestNG, I did not see any response in appium server and also the program executed within fraction of seconds and app was not launched.

Below is the code snippet for your reference
File classpathRoot = new File(System.getProperty(“user.dir”));
File appDir = new File(classpathRoot, “/Apps/WhatsApp/”);
File app = new File(appDir, “com.whatsapp-v2.12.347-450783-Android-2.1.apk”);
DesiredCapabilities capability = new DesiredCapabilities();
capability.setCapability(“deviceName”, “Moto G (2nd Generation)”);
capability.setCapability(“platformName”, “Android”);
capability.setCapability(“platformVersion”, “5.0.2”);
// File file = new File(“C:\Users\Somanath\Desktop\Practise\Appium_Started\App\com.whatsapp-v2.12.347-450783-Android-2.1.apk”);
capability.setCapability(“app”, app.getAbsolutePath());
capability.setCapability(“appPackage”, “com.whatsapp”);
capability.setCapability(“appActivity”, “com.whatsapp.MainActivity”);
driver = new AndroidDriver(new URL(“”), capability);

early help should be appreciated

Hi Udhay,

Did you resolve this issue, If so can you please let me know the action steps please.