Appium Is not working after xcode11 update

Good Day,

I updated xcode to 11 from 10 and after that i faced a strange issue, i searched for a lot of solutions but noting work. I also tried to update my tools and update the webagent but no luck

The issue appear when I execute my test case the app open and then the error thrown
We faced this on two macs and on differents simulators the log file is as below

from eclipse:
An unknown server-side error occurred while processing the command. Original error: Could not proxy command to remote server. Original error: Error: connect ECONNREFUSED 127.0.0.1:8100
Build info: version: ‘3.141.59’, revision: ‘e82be7d358’, time: ‘2018-11-14T08:17:03’

from appium:

[info] e[35m[Appium]e[39m Welcome to Appium v1.12.1
[info] e[35m[Appium]e[39m Non-default server args:
[info] e[35m[Appium]e[39m address: 127.0.0.1
[info] e[35m[Appium]e[39m Appium REST http interface listener started on 127.0.0.1:4723[info] e[35m[HTTP]e[39m e[37m–>e[39m e[37mPOSTe[39m e[37m/wd/hub/sessione[39m
[info] e[35m[HTTP]e[39m e[90m{“desiredCapabilities”:{“app”:"/Users/mohammadalhaj/ios/src/test/resources/Builds/ios.app",“platformVersion”:“12.1”,“automationName”:“XCUITest”,“autoGrantPermissions”:“true”,“platformName”:“iOS”,“udid”:“EEA97C54-8F15-47D7-AC75-0CA7FBE810CF”,“deviceName”:“iPhone 5s”,“autoAcceptAlerts”:“true”},“capabilities”:{“alwaysMatch”:{“appium:app”:"/Users/mohammadalhaj/ios/src/test/resources/Builds/ios.app",“appium:autoAcceptAlerts”:“true”,“appium:autoGrantPermissions”:“true”,“appium:automationName”:“XCUITest”,“appium:deviceName”:“iPhone 5s”,“platformName”:“ios”,“appium:platformVersion”:“12.1”,“appium:udid”:“EEA97C54-8F15-47D7-AC75-0CA7FBE810CF”},“firstMatch”:[{}]}}e[39m
[debug] e[35m[W3C]e[39m Calling AppiumDriver.createSession() with args: [{“app”:"/Users/mohammadalhaj/ios/src/test/resources/Builds/ios.app",“platformVersion”:“12.1”,“automationName”:“XCUITest”,“autoGrantPermissions”:“true”,“platformName”:“iOS”,“udid”:“EEA97C54-8F15-47D7-AC75-0CA7FBE810CF”,“deviceName”:“iPhone 5s”,“autoAcceptAlerts”:“true”},null,{“alwaysMatch”:{“appium:app”:"/Users/mohammadalhaj/ios/src/test/resources/Builds/ios.app",“appium:autoAcceptAlerts”:“true”,“appium:autoGrantPermissions”:“true”,“appium:automationName”:“XCUITest”,“appium:deviceName”:“iPhone 5s”,“platformName”:“ios”,“appium:platformVersion”:“12.1”,“appium:udid”:“EEA97C54-8F15-47D7-AC75-0CA7FBE810CF”},“firstMatch”:[{}]}]
[debug] e[35m[BaseDriver]e[39m Event ‘newSessionRequested’ logged at 1569240740088 (15:12:20 GMT+0300 (EEST))
[info] e[35m[Appium]e[39m Appium v1.12.1 creating new XCUITestDriver (v2.110.1) session
[info] e[35m[Appium]e[39m Capabilities:
[info] e[35m[Appium]e[39m platformName: ios
[info] e[35m[Appium]e[39m app: /Users/mohammadalhaj/ios/src/test/resources/Builds/ios.app
[info] e[35m[Appium]e[39m autoAcceptAlerts: true
[info] e[35m[Appium]e[39m autoGrantPermissions: true
[info] e[35m[Appium]e[39m automationName: XCUITest
[info] e[35m[Appium]e[39m deviceName: iPhone 5s
[info] e[35m[Appium]e[39m platformVersion: 12.1
[info] e[35m[Appium]e[39m udid: EEA97C54-8F15-47D7-AC75-0CA7FBE810CF
[debug] e[35m[BaseDriver]e[39m W3C capabilities {“alwaysMatch”:{“platformNa… and MJSONWP desired capabilities {“app”:”/Users/mohammadalha… were provided
[debug] e[35m[BaseDriver]e[39m Creating session with W3C capabilities: {“alwaysMatch”:{"platformNa…
[warn] e[35m[BaseDriver]e[39m Capability ‘autoAcceptAlerts’ changed from string to boolean. This may cause unexpected behavior
[warn] e[35m[BaseDriver]e[39m The following capabilities were provided, but are not recognized by appium: autoGrantPermissions.
[info] e[35m[BaseDriver]e[39m Session created with session id: 6cebdda2-0870-4f9f-9d28-6feebaf2895e
[debug] e[35m[XCUITest]e[39m Current user: ‘mohammadalhaj’[info] e[35m[iOSSim]e[39m Constructing iOS simulator for Xcode version 11.0 with udid ‘EEA97C54-8F15-47D7-AC75-0CA7FBE810CF’
[info] e[35m[XCUITest]e[39m Determining device to run tests on: udid: ‘EEA97C54-8F15-47D7-AC75-0CA7FBE810CF’, real device: false[info] e[35m[XCUITest]e[39m Xcode version set to ‘11.0’ (tools v10.3.0.0.1.1562985497)
[info] e[35m[XCUITest]e[39m iOS SDK Version set to ‘13.0’
[debug] e[35m[BaseDriver]e[39m Event ‘xcodeDetailsRetrieved’ logged at 1569240740688 (15:12:20 GMT+0300 (EEST))
[info] e[35m[BaseDriver]e[39m Using local app ‘/Users/mohammadalhaj/ios/src/test/resources/Builds/ios.app’
[debug] e[35m[BaseDriver]e[39m Event ‘appConfigured’ logged at 1569240740690 (15:12:20 GMT+0300 (EEST))
[debug] e[35m[XCUITest]e[39m Checking whether app ‘/Users/mohammadalhaj/ios/src/test/resources/Builds/ios.app’ is actually present on file system
[debug] e[35m[XCUITest]e[39m App is present
[debug] e[35m[iOS]e[39m Getting bundle ID from app ‘/Users/mohammadalhaj/ios/src/test/resources/Builds/ios.app’: ‘com.genie9.intellizoolz’
[debug] e[35m[BaseDriver]e[39m Event ‘resetStarted’ logged at 1569240740691 (15:12:20 GMT+0300 (EEST))[info] e[35m[XCUITest]e[39m Not scrubbing third party app in anticipation of uninstall
[debug] e[35m[BaseDriver]e[39m Event ‘resetComplete’ logged at 1569240741071 (15:12:21 GMT+0300 (EEST))[debug] e[35m[XCUITest]e[39m Starting log capture for iOS Simulator with udid ‘EEA97C54-8F15-47D7-AC75-0CA7FBE810CF’, using ‘xcrun simctl spawn EEA97C54-8F15-47D7-AC75-0CA7FBE810CF log stream --style compact’[debug] e[35m[BaseDriver]e[39m Event ‘logCaptureStarted’ logged at 1569240741695 (15:12:21 GMT+0300 (EEST))
[info] e[35m[XCUITest]e[39m Setting up simulator
[debug] e[35m[iOS]e[39m No reason to set locale
[debug] e[35m[iOS]e[39m No iOS / app preferences to set
[debug] e[35m[iOSSim]e[39m Setting preferences of EEA97C54-8F15-47D7-AC75-0CA7FBE810CF Simulator to {“ConnectHardwareKeyboard”:false}
[debug] e[35m[iOSSim]e[39m Setting common Simulator preferences to {“RotateWindowWhenSignaledByGuest”:true,“ConnectHardwareKeyboard”:false}
[debug] e[35m[iOSSim]e[39m Updated EEA97C54-8F15-47D7-AC75-0CA7FBE810CF Simulator preferences at ‘/Users/mohammadalhaj/Library/Preferences/com.apple.iphonesimulator.plist’ with {“DevicePreferences”:{“EEA97C54-8F15-47D7-AC75-0CA7FBE810CF”:{“ConnectHardwareKeyboard”:false}},“RotateWindowWhenSignaledByGuest”:true,“ConnectHardwareKeyboard”:false}
[debug] e[35m[iOSSim]e[39m Got Simulator UI client PID: 721
[info] e[35m[iOSSim]e[39m Both Simulator with UDID EEA97C54-8F15-47D7-AC75-0CA7FBE810CF and the UI client are currently running
[debug] e[35m[BaseDriver]e[39m Event ‘simStarted’ logged at 1569240741837 (15:12:21 GMT+0300 (EEST))
[debug] e[35m[XCUITest]e[39m Verifying application platform
[debug] e[35m[XCUITest]e[39m CFBundleSupportedPlatforms: [“iPhoneSimulator”][debug] e[35m[XCUITest]e[39m Reset requested. Removing app with id ‘com.genie9.intellizoolz’ from the device[debug] e[35m[XCUITest]e[39m Cleaning installd cache to save the disk space
[debug] e[35m[XCUITest]e[39m Installing ‘/Users/mohammadalhaj/ios/src/test/resources/Builds/ios.app’ on Simulator with UUID ‘EEA97C54-8F15-47D7-AC75-0CA7FBE810CF’…[debug] e[35m[XCUITest]e[39m The app has been installed successfully.
[debug] e[35m[BaseDriver]e[39m Event ‘appInstalled’ logged at 1569240753012 (15:12:33 GMT+0300 (EEST))
[info] e[35m[XCUITest]e[39m Using WDA path: ‘/Applications/Appium.app/Contents/Resources/app/node_modules/appium/node_modules/appium-xcuitest-driver/WebDriverAgent’
[info] e[35m[XCUITest]e[39m Using WDA agent: ‘/Applications/Appium.app/Contents/Resources/app/node_modules/appium/node_modules/appium-xcuitest-driver/WebDriverAgent/WebDriverAgent.xcodeproj’
[debug] e[35m[XCUITest]e[39m No obsolete cached processes from previous WDA sessions listening on port 8100 have been found
[debug] e[35m[WD Proxy]e[39m Matched ‘/status’ to command name ‘getStatus’
[debug] e[35m[WD Proxy]e[39m Proxying [GET /status] to [GET http://localhost:8100/status] with no body
[debug] e[35m[WD Proxy]e[39m Got response with status 200: “{\n “value” : {\n “state” : “success”,\n “os” : {\n “name” : “iOS”,\n “version” : “13.0”,\n “sdkVersion” : “13.0”\n },\n “ios” : {\n “simulatorVersion” : “13.0”,\n “ip” : “192.168.1.220”\n },\n “build” : {\n “upgradedAt” : “1554217107091”,\n “time” : “Sep 23 2019 14:41:53”,\n “productBundleIdentifier” : “com.facebook.WebDriverAgentRunner”\n }\n },\n “sessionId” : “B845344E-B7F0-40D2-BC64-4330EDE127AB”,\n “status” : 0\n}”
[debug] e[35m[XCUITest]e[39m Upgrade timestamp of the currently bundled WDA: 1554217107091
[debug] e[35m[XCUITest]e[39m Upgrade timestamp of the WDA on the device: 1554217107091
[info] e[35m[XCUITest]e[39m Will reuse previously cached WDA instance at ‘http://localhost:8100/’ with ‘com.facebook.WebDriverAgentRunner’. Set the wdaLocalPort capability to a value different from 8100 if this is an undesired behavior.
[debug] e[35m[XCUITest]e[39m Trying to start WebDriverAgent 2 times with 10000ms interval
[debug] e[35m[XCUITest]e[39m These values can be customized by changing wdaStartupRetries/wdaStartupRetryInterval capabilities
[debug] e[35m[BaseDriver]e[39m Event ‘wdaStartAttempted’ logged at 1569240753064 (15:12:33 GMT+0300 (EEST))
[info] e[35m[XCUITest]e[39m Using provided WebdriverAgent at ‘http://localhost:8100/
[debug] e[35m[WD Proxy]e[39m Matched ‘/status’ to command name ‘getStatus’
[debug] e[35m[WD Proxy]e[39m Proxying [GET /status] to [GET http://localhost:8100/status] with no body
[debug] e[35m[WD Proxy]e[39m Got response with status 200: “{\n “value” : {\n “state” : “success”,\n “os” : {\n “name” : “iOS”,\n “version” : “13.0”,\n “sdkVersion” : “13.0”\n },\n “ios” : {\n “simulatorVersion” : “13.0”,\n “ip” : “192.168.1.220”\n },\n “build” : {\n “upgradedAt” : “1554217107091”,\n “time” : “Sep 23 2019 14:41:53”,\n “productBundleIdentifier” : “com.facebook.WebDriverAgentRunner”\n }\n },\n “sessionId” : “B845344E-B7F0-40D2-BC64-4330EDE127AB”,\n “status” : 0\n}”
[debug] e[35m[BaseDriver]e[39m Event ‘wdaSessionAttempted’ logged at 1569240753069 (15:12:33 GMT+0300 (EEST))
[debug] e[35m[XCUITest]e[39m Sending createSession command to WDA
[debug] e[35m[WD Proxy]e[39m Matched ‘/session’ to command name ‘createSession’
[debug] e[35m[WD Proxy]e[39m Proxying [POST /session] to [POST http://localhost:8100/session] with body: {“desiredCapabilities”:{“bundleId”:“com.genie9.intellizoolz”,“arguments”:[],“environment”:{},“eventloopIdleDelaySec”:0,“shouldWaitForQuiescence”:true,“shouldUseTestManagerForVisibilityDetection”:false,“maxTypingFrequency”:60,“shouldUseSingletonTestManager”:true,“defaultAlertAction”:“accept”}}[debug] e[35m[WD Proxy]e[39m Got response with status 200: {“value”:{“sessionId”:“030E0477-422A-46F0-A576-3FCB4014BACF”,“capabilities”:{“device”:“iphone”,“browserName”:" ",“sdkVersion”:“13.0”,“CFBundleIdentifier”:“com.apple.springboard”}},“sessionId”:“030E0477-422A-46F0-A576-3FCB4014BACF”,“status”:0}
[debug] e[35m[BaseDriver]e[39m Event ‘wdaSessionStarted’ logged at 1569240758041 (15:12:38 GMT+0300 (EEST))
[debug] e[35m[BaseDriver]e[39m Event ‘wdaStarted’ logged at 1569240758041 (15:12:38 GMT+0300 (EEST))
[info] e[35m[XCUITest]e[39m Skipping setting of the initial display orientation. Set the “orientation” capability to either “LANDSCAPE” or “PORTRAIT”, if this is an undesired behavior.
[debug] e[35m[BaseDriver]e[39m Event ‘orientationSet’ logged at 1569240758042 (15:12:38 GMT+0300 (EEST))
[info] e[35m[Appium]e[39m New XCUITestDriver session created successfully, session 6cebdda2-0870-4f9f-9d28-6feebaf2895e added to master session list
[debug] e[35m[BaseDriver]e[39m Event ‘newSessionStarted’ logged at 1569240758044 (15:12:38 GMT+0300 (EEST))
[debug] e[35m[W3C (6cebdda2)]e[39m Cached the protocol value ‘W3C’ for the new session 6cebdda2-0870-4f9f-9d28-6feebaf2895e
[debug] e[35m[W3C (6cebdda2)]e[39m Responding to client with driver.createSession() result: {“capabilities”:{“webStorageEnabled”:false,“locationContextEnabled”:false,“browserName”:"",“platform”:“MAC”,“javascriptEnabled”:true,“databaseEnabled”:false,“takesScreenshot”:true,“networkConnectionEnabled”:false,“platformName”:“ios”,“app”:"/Users/mohammadalhaj/ios/src/test/resources/Builds/ios.app",“autoAcceptAlerts”:true,“autoGrantPermissions”:“true”,“automationName”:“XCUITest”,“deviceName”:“iPhone 5s”,“platformVersion”:“12.1”,“udid”:“EEA97C54-8F15-47D7-AC75-0CA7FBE810CF”}}
[info] e[35m[HTTP]e[39m e[37m<-- POST /wd/hub/session e[39me[32m200e[39m e[90m17959 ms - 541e[39m
[info] e[35m[HTTP]e[39m e[90me[39m[info] e[35m[HTTP]e[39m e[37m–>e[39m e[37mGETe[39m e[37m/wd/hub/session/6cebdda2-0870-4f9f-9d28-6feebaf2895ee[39m
[info] e[35m[HTTP]e[39m e[90m{}e[39m
[debug] e[35m[W3C (6cebdda2)]e[39m Calling AppiumDriver.getSession() with args: [“6cebdda2-0870-4f9f-9d28-6feebaf2895e”]
[debug] e[35m[XCUITest]e[39m Executing command ‘getSession’
[debug] e[35m[WD Proxy]e[39m Matched ‘/’ to command name ‘getSession’
[debug] e[35m[WD Proxy]e[39m Proxying [GET /] to [GET http://localhost:8100/session/030E0477-422A-46F0-A576-3FCB4014BACF] with no body[warn] e[35m[WD Proxy]e[39m Got an unexpected response: {“errno”:“ECONNREFUSED”,“code”:“ECONNREFUSED”,“syscall”:“connect”,“address”:“127.0.0.1”,“port”:8100}
[debug] e[35m[W3C (6cebdda2)]e[39m Encountered internal error running command: UnknownError: An unknown server-side error occurred while processing the command. Original error: Could not proxy command to remote server. Original error: Error: connect ECONNREFUSED 127.0.0.1:8100
[debug] e[35m[W3C (6cebdda2)]e[39m at JWProxy.command (/Applications/Appium.app/Contents/Resources/app/node_modules/appium/node_modules/appium-base-driver/lib/jsonwp-proxy/proxy.js:236:13)
[info] e[35m[HTTP]e[39m e[37m<-- GET /wd/hub/session/6cebdda2-0870-4f9f-9d28-6feebaf2895e e[39me[31m500e[39m e[90m14 ms - 605e[39m
[info] e[35m[HTTP]e[39m e[90me[39m[debug] e[35m[XCUITest]e[39m Log file for xcodebuild test: /Users/mohammadalhaj/Library/Developer/Xcode/DerivedData/WebDriverAgent-dikkwtrisltbeobjmfvpthwwekvs/Logs/Test/Test-WebDriverAgentRunner-2019.09.23_15-11-49-+0300.xcresult/Staging/2_Test/Diagnostics/WebDriverAgentRunner-318C623F-6A58-4C66-8A27-D0A11EECC59A/WebDriverAgentRunner-B2584993-4084-49A3-A2C7-746C27FC8364/Session-WebDriverAgentRunner-2019-09-23_151316-2hZc0p.log[error] e[35m[XCUITest]e[39m xcodebuild exited with code ‘65’ and signal ‘null’

1 Like

@malhaj88 tried with appium beta?

npm install -g [email protected]
1 Like

Hi @Aleksei
thx a lot for the response
after using the beat i’m still facing the same issue, I rebooted the mac and erase the simulator contents do you think I have to update another thing?

we did not move to xcode11 yet. does error still same? add your logs at https://gist.github.com/ - not in forum. hard to read…

Yes, the same error still displays
please review the below link

@malhaj88 first line in log:
[info] e[35m[Appium]e[39m Welcome to Appium v1.12.1

wrong appium! expected something: 1.15.0-beta.X

Man help me here please
the version 1.12 is for the appium desktop application

but when I execute appium -v on my mac the version is
1.15.0-beta.1

they are different. how you start appium in test code?

I started it like this
driver = new AppiumDriver( new URL(“http://0.0.0.0:4723/wd/hub”), AppiumContext. capabilities )

in your code example you start ‘driver’ not appium ‘server’.

looks like you starting appium server manually in GUI.
if it true you need switch start it in command line (or terminal if it MacOS) with:

appium

command. you may also add some parameters depending of your need e.g. i am with:

appium --log-level error --port 4723 --command-timeout 300 --session-override --log-timestamp

or you can switch to start appium right in test code.

1 Like

Yes, I’m using the appium GUI to start the server.

Now when I started the server from the command line this is fixed the issue thx a lot man
and started the appium 1.15 version

But i need a help with something please
when I get the locaters for my app i’m using the appium desktop GUI to connec to to the server and open the app within it, but now i can’t do this because the issue will appear when I connect the server from it
what should I do in this case?

Can we start the latest appium beta from the GUI appium application?

You may see your page source in:

System.out.println(driver.getPageSource());

On needed screen

Ah yes good idea
for me the issue is fixed
thx a lot Man :heart_eyes:

How did you install WebDriverAgent from Appium 1.15.0. I don’t see it in the directory,…