Appium is unable to locate element for android version 7.0 and above with all the appium version (1.6.X ,1.7.X, 1.8.X)


#1

Hi Appium Team,

We are facing strange behavior from Appium where it is failing to locate an element for android version 7.X.X and above. But it is working fine for Android Version 6.X

Scenario:
Let user is at screen A and then he performs some action -> after action user remains on the same screen A. Now Appium is unable to locate the elements of Screen A.
If i do background and foreground from this screen, appium starts locating the element.

Could you please check and help us on this.


#2

Hi Team,

I am also facing a likely problem with appium dmg (v1.8.1)
My script is working fine on Android version 6.0 (Moto) but the same script is not working on other devices like (Samsung Android 6.0.1 and Oneplus Android 7.1).
While going through the Appium logs I found that
The locator’s value and for few elements types are getting changed in Samsung and OnePlus.
eg (List is returning less number of elements also
In place of locator ‘text’ data is coming in ‘content-desc’,
few elements are not even present in OnePlus and Samsung but have locator and value defined in Moto).

Any suggestions for the workaround …or remedy for it …?


#3

Hi Team,

I am facing some issues in locating elements in a IOS native iPad application:
For clicking a button inside a frame, I am not able to locate that particular element in appium inspector. If I try to use locators for different areas of that button in my script, it shows an error in console saying “element could not be found”.
I tried switchTo.frame() also to locate the element but it didnt work.

Could you please help in solving the issue


#4

Hi Team,

I encountered a problem in locating elements in native iOS app:
I am able to get locators like id or XPath for clicking some images of the app screen through appium inspector but using those locators in our script do not execute tests in runtime & gives no error in console. I tried using longpress of Touchactions class for clicking those images but it failed.
Please find the appium logs below

[JSONWP Proxy] Replacing sessionId BA1222CA-578F-4F99-8C6D-F3B96A99B5A3 with 431b531f-486a-4be3-a6df-bb7fa8f62f32
[HTTP] <-- POST /wd/hub/session/431b531f-486a-4be3-a6df-bb7fa8f62f32/element/DB9FBA62-C640-40BE-A37E-8ADBB0334EE7/click 200 1629 ms - 118
[HTTP] --> POST /wd/hub/session/431b531f-486a-4be3-a6df-bb7fa8f62f32/element {“using”:“id”,“value”:“Sikkens - Intérieur”}
[MJSONWP] Calling AppiumDriver.findElement() with args: [“id”,“Sikkens - Intérieur”,“431b531f-486a-4be3-a6df-bb7fa8f62f32”]
[XCUITest] Executing command ‘findElement’
[BaseDriver] Valid locator strategies for this request: xpath, id, name, class name, -ios predicate string, -ios class chain, accessibility id
[BaseDriver] Waiting up to 2000 ms for condition
[JSONWP Proxy] Proxying [POST /element] to [POST http://localhost:8100/session/BA1222CA-578F-4F99-8C6D-F3B96A99B5A3/element] with body: {“using”:“id”,“value”:“Sikkens - Intérieur”}
[JSONWP Proxy] Got response with status 200: {“value”:{“ELEMENT”:“8ADF7500-14CB-40C0-9691-15F66BC1A3AF”},“sessionId”:“BA1222CA-578F-4F99-8C6D-F3B96A99B5A3”,“status”:0}
[MJSONWP] Responding to client with driver.findElement() result: {“ELEMENT”:“8ADF7500-14CB-40C0-9691-15F66BC1A3AF”}
[HTTP] <-- POST /wd/hub/session/431b531f-486a-4be3-a6df-bb7fa8f62f32/element 200 814 ms - 122
[HTTP] --> POST /wd/hub/session/431b531f-486a-4be3-a6df-bb7fa8f62f32/element/8ADF7500-14CB-40C0-9691-15F66BC1A3AF/click {“id”:“8ADF7500-14CB-40C0-9691-15F66BC1A3AF”}
[MJSONWP] Driver proxy active, passing request on via HTTP proxy
[XCUITest] Executing command ‘proxyReqRes’
[JSONWP Proxy] Proxying [POST /wd/hub/session/431b531f-486a-4be3-a6df-bb7fa8f62f32/element/8ADF7500-14CB-40C0-9691-15F66BC1A3AF/click] to [POST http://localhost:8100/session/BA1222CA-578F-4F99-8C6D-F3B96A99B5A3/element/8ADF7500-14CB-40C0-9691-15F66BC1A3AF/click] with body: {“id”:“8ADF7500-14CB-40C0-9691-15F66BC1A3AF”}
[JSONWP Proxy] Got response with status 200: {“status”:0,“id”:“8ADF7500-14CB-40C0-9691-15F66BC1A3AF”,“value”:"",“sessionId”:“BA1222CA-578F-4F99-8C6D-F3B96A99B5A3”}
[JSONWP Proxy] Replacing sessionId BA1222CA-578F-4F99-8C6D-F3B96A99B5A3 with 431b531f-486a-4be3-a6df-bb7fa8f62f32
[HTTP] <-- POST /wd/hub/session/431b531f-486a-4be3-a6df-bb7fa8f62f32/element/8ADF7500-14CB-40C0-9691-15F66BC1A3AF/click 200 1538 ms - 118
[BaseDriver] Shutting down because we waited 60 seconds for a command
[Appium] Closing session, cause was ‘New Command Timeout of 60 seconds expired. Try customizing the timeout using the ‘newCommandTimeout’ desired capability’
[Appium] Removing session 431b531f-486a-4be3-a6df-bb7fa8f62f32 from our master session list
[XCUITest] Setting ‘755’ permissions to ‘/Users/mashboob/Library/Developer/Xcode/DerivedData/WebDriverAgent-dikkwtrisltbeobjmfvpthwwekvs/Logs/Test/Attachments’ folder
[XCUITest] Not clearing log files. Use clearSystemFiles capability to turn on.
[iOSLog] Stopping iOS log capture

Please go through it once and help in solving the issue


#5

我也遇到了这个问题,让更多的人看到吧 啦啦啦啦啦啦啦啦绿绿绿绿绿绿绿绿绿绿绿绿


#6

I do have same issue with ReactNative application please anyone help me out.