Appium + Robot Framework + Webview Context

I am using Robot Framework and importing the Appium Library. I have a username and password fields in a webview.

I made sure that it shows both the WEBVIEW_1 and NATIVE_APP contexts so i tried

Switch to Context WEBVIEW_1
Input Text ${username} test123
Input Text ${password} 123test
Switch to Context NATIVE_APP

The issue is that it couldn’t find the keywords even thought i used the correct name parameter, it still finds the elements that aren’t in the webview. So this made me suspect that the webview wasn’t being given focus. So i tried.

${context}= Get Variable Value Get Current Context
Error: Invalid variable syntax ‘Get Current Context’.
${context}= Set Variable Get Current Context
Error: No keyword with name ‘Log ${context}’ found

Not only is it proving to be a pain to change the context, but it won’t even let me use Log to display my current context.
Log Get Current Context
Error: Treats it as text and outputs INFO : Get Current Context

Any help would be greatly appreciated! Thanks guys. iOS app btw.

Is there any solution on Switch to Context?

@{all_contexts}=     get contexts
log to console      @{all_contexts}[0]
log to console      @{all_contexts}[1]
switch to context   @{all_contexts}[1]