Appium server not responding on but does on

I have an appium server started by code. i’m trying to ping it via browser.

OS: Windows 10 latest update
Appium server version: 1.9.0
Platform: connecting via chrome

forgot to mention but this problem started when i tried to connect via .Net Core’s AndroidDriver to an emulator.
if i connect to i get errors, but if i connect to localhost:27721/wd/hub everything works fine

you should add it to host file

Thannk you for the prompt response. Unfortunately, this did not work. I’ve tried adding the following lines with no success:

  2. (i know this isn’t the syntax but why not try :slight_smile: )
    having read up i found that represents a non-routable path (see any suggestions on how to proceed?


when you on mac use:
when you are on windows use: or http://localhost:4723/wd/hub

I have the same problem when using Ruby to connect. It’s ok if I use Java.
If you can not connect to the default host, you should change the default host to another then try again.

Hi @Aleksei , quick question. What if i want to start Appium server on mac on port 4723 ?
My code :
public void startAppium() throws Exception {
//String[] OS_LINUX_RUNTIME = { “/bin/bash”, “-l”, “-c” };
String command = “/bin/bash -l -c appium --session-override -p 4724”;
String output = runCommand(command); //run command on terminal
But problem is:
e[35m[Appium]e[39m Appium REST http interface listener started on

Not sure why it started on 4723.
Please help

@gunjan_kapoor when you do same in console does it behave same? Try change “-p” to “–p”.