Appium Server v1.3.0-beta1 Released

Hello everyone,

At long last, a usable beta which includes iOS8 support has been released:

Please check it out and leave feedback. We’d like to release v1.3.0 in about a week’s time after fixing some bugs. Known bugs are being tracked and dealt with in this milestone:

PLEASE NOTE: in iOS8 simulators there are two additional setup steps (already detailed in the 1.3.0-beta1 docs):

  1. make sure the keyboard settings are correct in the iOS sim menu. The soft keyboard needs to be enabled. Otherwise sendKeys won’t work.

  2. make sure that “Enable UI Automation” is turned on in the new “Developer” section in the Settings app.



Where can we find the 1.3.0-beta1 docs?

In the /docs folder of the github repository.

1 Like

Oh, in here?

1 Like

yes, that’s where they live right now. It’s not published yet. The relevant bits are in the osx setup doc.

Hi There,
FIrst of all thanks everybody for getting this 1.3 beta out.
Initial tests of mine seem really good. The documentation here listed was quite helpful!

So unfortunately, while I have success in the simulator I do not have success with the device.
I made sure that in device settings > UI Automation is turned on.

I am running from the latest in the iOS 8 branch.
I run node like this. I verified the bundle Identifier in Xcode > Devices:
node . -U 4899a57feb80cdc32d31a23b603a769b3d9214c6 --app “com.blackboard.testing.enterprise.grader”

The test starts, but instruments is now throwing this error:
[INST STDERR] 2014-10-07 10:50:14.241 instruments[7441:1307] WebKit Threading Violation - initial use of WebKit from a secondary thread.

Not sure if this is an issue or if there’s something with my setup.

Thanks in advance for any help!

Sorry, one caveat here is that I’m still on the latest beta of iOS 8 when I ran this test. I had side-by-side xcode 5 and 6. I made sure xcode-select was pointed to Xcode 6. Still, perhaps it’s possible this error goes away when I upgrade to GM?


noob question

is there any why that i can update my Appium App.dmg to v 1.3.0

@sai_tvs No.

At the earliest, it will be when the official version is released. After that the contributors will need to prep and compile the .dmg for release.

Thanks @JessicaSachs

How can i use or start 1.3 appium on mac?

how to run it from source?

You’ll want to do
git checkout v1.3.0-beta1

before you do


to use the beta version.


First of all I want to say thank you to the Appium team for creating such beautiful framework. I am really enjoying the benefit of Appium.

For now I have a question that does 1.3.0 fix the issue of 1 second delay? I have pulled out the source code and tried to run from there but still got that delay.


@jlipps opening soft keyboard did the trick for sendKeys but I wonder what you would do for appium sauce cloud when you are going to have ios8 simulators there

we’ll have it set correctly in our image.

Hi guys, any one can tell me how I can use methods such as swipe in the new Beta 1.3.

I am using eclipse to run my tests against a iPhone 6 simulator