Appium session not running with WebdriverIO

Environment

  • WebdriverIO version: [6.0.13]
  • Mode: [WDIO Testrunner]
  • If WDIO Testrunner, running sync/async: [sync]
  • Node.js version: [14.4.0]
  • NPM version: [6.14.5]
  • Browser name and version: [Chrome]
  • Platform name and version: [Windows 10]

Config of WebdriverIO
Appium Config:

services: [
        [
            "appium",
            {
                // For options see
                // https://github.com/webdriverio/webdriverio/tree/master/packages/wdio-appium-service
                args: {
                    // ...
                    debugLogSpacing: true,
                    platformName: "android",
                    // ...
                },
                command: "appium",
            },
        ],
    ],
    port: 4723, 

   config.capabilities = [
    {
        // The defaults you need to have in your config
        platformName: "Android",
        browserName: "chrome",
        maxInstances: 1,
        // For W3C the appium capabilities need to have an extension prefix
        // http://appium.io/docs/en/writing-running-appium/caps/
        // This is `appium:` for all Appium Capabilities which can be found here
        "appium:deviceName": "Pixel_2_XL_API_29",
        "appium:platformVersion": "11",
        "appium:orientation": "PORTRAIT",
        // `automationName` will be mandatory, see
        // https://github.com/appium/appium/releases/tag/v1.13.0
        "appium:automationName": "UiAutomator2",
        "appium:newCommandTimeout": 240,
        "goog:chromeOptions": {
            w3c: true,
            // Add this option to prevent the annoying "Welcome"-message
            args: ["--no-first-run"],
        },
    },

Describe the bug
Not able to create a session with Appium. Getting error Unable to connect to "http://localhost:4723/", make sure browser driver is running on that address.

If I run Appium instance separately then I get this error: ERROR webdriver: Error: The URL '/session' did not map to a valid resource

To Reproduce
I’m using the appium-boilerplate , no changes made to it other than the deviceName and platformVersion

Expected behavior
Be able to run tests in Android simulator

Could the Windows 10 firewall be blocking this port by default? Try turning off the firewall and if you get connection you’ll need to figure out how to open the port.

@wreed Thanks for replying.

I tried running even with Firewall off, it’s still the same issue. I’m able to run appium on the 4723 port but my tests are not able to connect to the appium server.
If I run appium server separately then I get this error - ERROR webdriver: Error: The URL '/session' did not map to a valid resource

You probably need to explicitly provide the path like it was done in https://github.com/appium/appium/pull/14471/files

I’m having the same issue. App is not launching. I get the same /session error when trying to run server on appium desktop.