Appium setup on Ubuntu

Hello ,
I am trying to setup appium on ubuntu 14.04 and while running the reset.sh i get the following error.
RESETTING GENERAL

  • Setting git revision data
    ---- FAILURE: reset.sh exited with status 1 ----
    i also tried using npm but that gets stuck again at:
    “error trying to install chromedriver binary”
    How do I fix this? Please help!!

You should be able to get more logs if you run reset.sh with the “–verbose” flag.

I tried that and I get a few warnings saying that package.json is not a repository field. There are no errors but it fails. Npm isn’t helping either

Can you post a link to a pastebin of the logs? https://paste.ubuntu.com/

Yes, here is the link to that.
https://paste.ubuntu.com/15339595/
Also the master branch did not have the reset.sh file so I checked it out from a branch called 0.18.x.
Here is the GitHub link.


Furthermore when i did git clean-dfx and git reset --hard I got the following errors.
https://paste.ubuntu.com/15339667/

Ah, there’s your problem. The reset.sh script was removed for the 1.5 series because many of Appium’s dependencies were moved into their separate NPM separate projects, making the Appium set-up process cleaner as a result.

Clean your Appium working directory, checkout version 1.5.0 (you can find the version tags by running git tag), and then run npm install. npm install will read the shrinkwrap.json or package.json file sitting in the project directory (whichever comes first) and download Appium’s dependencies that way. No more reset.sh is needed. :slight_smile:

I will do as you say. Thank you for the timely help :slight_smile:
While installing through npm I get an error saying , “trying to install chromedriver binary. Waiting and trying again.”
I checked out from branch 1.5 and then even tried the beta version. On one GitHub thread they asked me to clone chromedriver repo and install manually and I did that but it is not installing and it shows the above mentioned error