Appium test on real iOS device - Cannot build WebDriverAgentRunner

I have …

  • Installed Appium and the xcui driver
  • Navigated to the path /Users/buildagent/appium/node_modules/appium-xcuitest-driver/node_modules/appium-webdriveragent
  • Done the “mkdir -p Resources/WebDriverAgent.bundle” command and then created a file inside the folder /Scripts, then run “./Scripts/ -d”
  • Opened the WebDriverAgent project and configured both WebDriverAgentLib and WebDriverAgentRunner check the Automatic signing checkbox and set the team to my personal team (note that I don’t have a paid version of apple dev.)
  • WebDriverAgentRunner was also configured with a unique bundle id
  • The IntegrationApp in the same project was also updated with my team and yet another unique bundle id

If I run xcodebuild -project WebDriverAgent.xcodeproj -destination ‘id=…’ then it builds green and it says something about signing. But if I run xcodebuild -project WebDriverAgent.xcodeproj -scheme WebDriverAgentRunner -destination ‘id=…’, then it fails “No profiles for com…WebDriverAgentRunner.xctrunner were found: xcode couldn’t find any ios app developemtn provisioning profiles matching com…WebDriverAgentRunner.xctrunner”.

All the guides are saying the solution is to change the bundle id, but I already did that.

If I run my tests which are in Visual studio, via “dotnet test”, then it’s showing me the same errors and it’s pointing to the same bundle id.

I got a paid apple developer account from my company and then it worked out well. However, my understanding is that it should work without a paid version?

without paid version only on simulator :slight_smile:

Oh really… Thanks for the update :slight_smile: