Appium UIAutomatorViewer has error

I am using Macbook Air M1, MacOS 13.2.1, but having following error when open uiautomatorviewer by using terminal

swt folder ‘/opt/homebrew/caskroom/android-sdk/4333796/tools/lib/aarch64’ does not exist. please export android_swt to point to the folder containing swt.jar for your platform.

I had tried following solution but still not working

  1. changed different JAVA_HOME on .bash_profile
  2. copy and paste swt.jar to above mentioned aarch64 folder
  3. set the path on ANDROID_SWT (path in below)
  4. try installed jdk8

The following is env variables, which I have already set “ANDROID_SWT”
export PATH=~/Library/Android/sdk/platform-


export ANDROID_HOME=/Users/$USER/Library/Android/sdk

export PATH=${PATH}:$ANDROID_HOME/tools:$ANDROID_HOME/platform-tools

export ANDROID_SWT=/Users/raymond/Library/Android/sdk/tools/lib/x86_64

export JAVA_HOME=/Users/raymond/Library/Java/JavaVirtualMachines/corretto-1.8.0_332/Contents/Home

export PATH=$JAVA_HOME/bin:$PATH

May I know what I am missing? thank you

this is for INTEL CPU but you have M1!

so may I know the expected path for M1 please? thanks