Appium update to V1.10.0 not exist in the list of simctl SDKs


#1

after xcode update for the latest sdk 12.2 version,
I have to use 12.1 sdk to run the test,
alreay go to preference to download 12.1 sdk,

appium version V1.12.1
appium desktop V1.10.0
xcode V10.2

the error still comes below
need help

An unknown server-side error occurred while processing the command. Original error: ‘12.1’ does not exist in the list of simctl SDKs. No Simulator SDK versions are available on your system. Please install some via Xcode preferences.

xcrun simctl list at below attachment
xcrun list.txt (11.3 KB)


#2

Same here. Already have downgraded xcode but error still exists


#3

Finally, I made it work :slight_smile:

so my steps were:

after downgraded xcode version to 10.1 because on 10.2 the config changed a bit that’s why appium cannot see any simulators.

I deleted all folders from /Library/Developer

And in xcode selected to install missing components

And once again installed selected iOS versions for simulators

After that, I was able to run tests again

(I am using appium 1.10)


#4

I have the same error. Seems that the problem is the appium does not support the latest xcode 10.2. I assume it will be better to release patch for the appium to support it because xcode with 10.2 allows to use the latest 12.2 iOS.


#5

I will try it and update whether this solusion is work :grinning: ~
thanks @gintare @Geezza


#6

Hello @gintare,

After follow the instructions from you, it’s not work on mine case.
I delete folders from Developer and rebuild simulator.
roll back my xcode to 10.1 and appium 1.12.0


#7

Hello @ann60319,
I haven’t tried with Appium 1.12 :slight_smile: still using 1.10. Also for a couple of times, I reinstalled Appium itself, sorry to hear that this solution hasn’t helped. Hope you will find yours and let me know what helped you


#8

Hi guys,

This morning I’ve tried to install new appium release v1.12.0 with previously installed xcode 10.1 and it works!!
Hope this solution works for you too.


#9

@Doer_Alpha thank you so much, it works on my case now :grinning:
@gintare thanks for help :+1:

now I use xcode 10.1 and appium-desktop V1.12.0 appium V1.12.0 to run test


#10

@Doer_Alpha, @ann60319 - the reason the discussed problem is in Xcode version 10.2 (prior version 10.1 works fine).


#11

@Geezza hope appium will update to support the latest xcode 10.2 and 12.2 sdk soon.
I still need an environment that’s work for me to keep runing my test, though that’s not the perfect solution :disappointed_relieved:


#12

I updated appium desktop and server to 1.12.1 version and tried it with the latest xcode version 10.2 - and there is no discussed issue anymore. Appium 1.12.1 has required fix. Try these versions for Appium and Xcode on your side.


#13

@gintare thanks a lot you saved me