Appium XCUITest some of the UITableView the screen elements are not able to inspect


#1

Hi , I am trying to automate ios native app with appium XCUITest . But when working with some of the UITableView the screen elements are not able to inspect. I am really blocked with my automation. Thanks in advance for the help…

Appium server version: v1.9.0(appium-desktop)
OS version :11.4

Issue faced:

  1. UITableView been provided with accessibility for table and to the cell view elements within the table but all the cells within the table is not loading and so not able to inspect.
  2. Tried again by setting the accessibility only for the cells not for table , but still fails to inspect the elements. When we are not setting the accessibility for UITable view, then app is closing and inspector window not able to load screenshot.
    Error displayed as shown below
    [HTTP] <-- GET /wd/hub/session/5107cc32-d019-4b4f-9953-a02afe585c0f/window/current/size 200 2 ms - 98
    [HTTP]
    [XCUITest] Connection to WDA timed out
    [iProxy] recv failed: Operation not permitted


#2

try this one to access the first cell
//XCUIElementTypeCell[1]


#3

Thanks for the reply.
But it is not listing any cells. I cannot see any cells/items within the table.


#4

go to inspect select xpath from dropdown list the past //XCUIElementTypeCell[1] and click on search and let me know what the result.


#5

The inspector shows nothing, can you see the screenshot i attached above. I highlighted the table, but no cells displayed under it to inspect.


#6

you need to ask your developer how he implement this table or you should refresh source again maybe not all elements rendering


#7

I am really stuck with these table view (not all the table views having problem only some having issues, which is of really important within my flow) . Developer sat with me and we have done many tests to set the accessibility for table view and followed many ways. Some of them shown below. But still not loading.Not sure if anything more need to set.


https://robkerr.com/understanding-ui-testing-using-ios-xcode-9-and-swift-c66a49eb8469


#8

Hi , Finally i found what the issue is. If the table having many items, say more than 600 cell items, the inspector is not loading the table cell items, also displays the timeout message from XCUITest driver logs after a long time.
I tried the same table view with less number of list items, then it worked perfectly. I am not sure why appium XCUITest driver cannot handle this. Is similar issue anyone faced …Is it in any chance it can be fixed?.. Please advice.


#9

You can try turn on the voiceover on device, and execute script again. It’s worked for me. Good luck!


#10

Hey, Great…It worked to load the data in Appium inspector.
But now my question is that it is not working when i am running the test , do we need to turn it off the voice over to run the script. I am invoking appium programatically for running my test scripts.
I am also facing super slowness when looping through the table cells eventhough i am using the accessibility . Are you facing this kind of issue?