At times adb not showing android device connected even it is connected/online

Some times when I do “adb devices” I found the following result from adb server:

C:\Windows\SysWOW64>adb devices
List of devices attached

  • daemon not running. starting it now on port 5037 *
    error: could not install smartsocket listener: cannot bind to
    Only one usage of each socket address (protocol/network address/port) is normall
    y permitted. (10048)
    could not read ok from ADB Server
  • failed to start daemon *
    error: cannot connect to daemon

I have a workaround for this which is to kill the adb forcefully from the windows task manager manually but I would like to know what exactly is leading me to this problem.

Can you please try
adb kill-server
adb start-server
adb reconnect device

I already tried, this didn’t worked.
I have a workaround on this, only forceful termination of adb solves this issue (either by killing through task manager or restarting the PC).
I want to know the exact source which is leading to this error or else something by which i can avoid this error.