AVD not showing up in drop-down selection

I have appium (windows) installed. I’m trying to launch the AVD emulator with starting the server. However, I do not see the devices created in the drop-down? Is there a fix for this?

What can I do to trouble shoot this further?

You should be able to just type in the name of your AVD in that field.

I’m not able to type in the name? I have previously setup the AVD device using Android Studio’s AVD manager, must I have the device emulator up and running independent of appium?

Install all packages for API 23 in Android SDK manager. Also make sure that you have chosen correct Platform Version

@kopytko: I’ve installed all API 23 packages and still not seeing, nor able to type in the name of the AVD device? Assuming the AVD is not running?

I’m using a Mac, so what I’m seeing may be different, but one thing I noticed is that if I enter the emulator name as seen in the AVD Manager (with spaces), Appium can’t find the emulator. For instance, the name of my emulator in AVD is called “Nexus 5X 5.1.1”. If I enter this exact text in the “Launch AVD” field, Appium log shows that it tried to find the emulator, and then says “emulator Nexus 5X 5.1.1 not running” (even if it is up and running). If I use underscores for the spaces in the emulator name in the Launch AVD field, like “Nexus_5X_5_1_1”, then it finds the emulator (whether it’s running or not running.

Regarding "not being able to type in the Launch AVD field, I still don’t know why that is happening, but maybe the Mac interface behaves differently.

not sure about MAC, but can’t even enter the AVD name when using Android?