BadParametersError and NotImplementedError on timeout cmds


#1

Hi all. On windows starting appium desktop and protractor test run gives me an error. I have used the same stack with same versions (appium, protractor, cucumber) on MacOS and did not get this error.

I am using appium desktop v1.10.0. Protractor v5.4.2 and Cucumber v2.3.1.

At https://gitter.im/appium/appium; there is another one wo is getting same sort of errors when setting timeouts…

[HTTP] --> POST /wd/hub/session/f553f655-20bd-4221-ae0f-7e0ac6aa450d/timeouts
[HTTP] {“script”:11000}
[MJSONWP (f553f655)] Encountered internal error running command: BadParametersError: Parameters were incorrect. We wanted “MJSONWP protocol requires type and ms” and you sent {“script”:11000}
[MJSONWP (f553f655)] at checkParams (C:\Program Files (x86)\Appium\resources\app\node_modules\appium-base-driver\lib\protocol\protocol.js:177:15)
[MJSONWP (f553f655)] at asyncHandler (C:\Program Files (x86)\Appium\resources\app\node_modules\appium-base-driver\lib\protocol\protocol.js:335:7)
[MJSONWP (f553f655)] at app.(anonymous function) (C:\Program Files (x86)\Appium\resources\app\node_modules\appium-base-driver\lib\protocol\protocol.js:489:15)

[HTTP] --> POST /wd/hub/session/f553f655-20bd-4221-ae0f-7e0ac6aa450d/timeouts
[HTTP] {“type”:“script”,“ms”:11000}
[MJSONWP (f553f655)] Calling AppiumDriver.timeouts() with args: [“script”,11000,null,null,null,“f553f655-20bd-4221-ae0f-7e0ac6aa450d”]
[BaseDriver] MJSONWP timeout arguments: {“type”:“script”,“ms”:11000}}
[MJSONWP (f553f655)] Encountered internal error running command: NotImplementedError: Not implemented yet for script.
[MJSONWP (f553f655)] at AndroidUiautomator2Driver.commands.scriptTimeoutMJSONWP (C:\Program Files (x86)\Appium\resources\app\node_modules\appium-base-driver\lib\basedriver\commands\timeout.js:100:9)
[MJSONWP (f553f655)] at AndroidUiautomator2Driver.commands.timeouts (C:\Program Files (x86)\Appium\resources\app\node_modules\appium-base-driver\lib\basedriver\commands\timeout.js:28:20)
[MJSONWP (f553f655)] at curCommandCancellable._bluebird.default.resolve.then (C:\Program Files (x86)\Appium\resources\app\node_modules\appium-base-driver\lib\basedriver\driver.js:291:18)


#2

Hi I’m getting the same error…


#3

Hi, I catch the same error,
so I found a solution in doccumentation http://appium.io/docs/en/writing-running-appium/caps/
I 've replaced autoWebView to autoWebview


#4

Hi, that wasn’t the issue unfortunately… You are correct that autoWebView vs autoWebview leads to a BadParameters error, but my parameters were correct. Updating to Appium v1.10.1 solved my problem.


#5

thanks, I’ll update my Appium too…