Best way to get xpath for iOS native app elements?

Have been using appium inspector all the time. But appium inspector no longer working with the combinations of
iOS 10.0 or lower + Mac OS El caption + Appium 1.5.2 (software) + Java 1.7.0 or 1.8 + Xcode 8.0 or 8.1
I’m using Appium 1.6.0 for command line level testing.

For android we do have tools to find the hierarchy but is there anything else for iOS.

Not sure if Ruby console will help for this ?
Looked into the tool Reveal, but it needs dev work. So not an option for me
Also used the accessiblity inspector on Mac but not much help with the xpath.

Any other suggestions.

Errors I get:
Encountered internal error running command: Error: Command failed: ideviceinstaller -u 13FAA60D-CB5A-42CF-94B0-BF1866B6E74E -l

Tried to fix it with upgrading node, unliking and linking ideviceinstaller and its parent library forgot the name.

Also followed these instructions:

Ok looks like the appium inspector will not work with xcode 8.

Ok after trying with Xcode 7.3.1 getting the following error

MJSONWP] Encountered internal error running command: Error: Xcode version [object Object] is not yet supported
at handleUnsupportedXcode (lib/simulator.js:15:11)
at getDeviceString$ (lib/simulator.js:44:3)
at tryCatch (/Applications/
at GeneratorFunctionPrototype.invoke [as _invoke] (/Applications/
at GeneratorFunctionPrototype.prototype.(anonymous function) [as next] (/Applications/
at GeneratorFunctionPrototype.invoke (/Applications/
at run (/Applications/
at /Applications/
at flush (/Applications/$.microtask.js:19:5)
at _combinedTickCallback (internal/process/next_tick.js:67:7)
at process._tickCallback (internal/process/next_tick.js:98:9)

Ok fixed it myself. This is due to 2 versions of xcode. so deleted Xcode 8.0 and left 7.3.1 on my mac

Now got the error that its not able to determine the xcode version
Could not get Xcode version. /Library/Developer/Info.plist does not exist on disk

So used this command to fix it.
sudo xcode-select --switch /Applications/Xcode\