Can appium 1.4.8 use latest node.js 0.12.14 version , instead of node.js 0.12.7 version

For appium 1.4.8, the build file contain node.js 0.12.7.
what we wan to know is that whether can use node.js latest version 0.12.14 or appium 1.4.8.

due to some special reason we can only use appium 1.4.8 for our purpose now, and can’t upgrade appium.
Why we need to use node.js higher 0.12 version is that: It is found there is known vulnerabilities in node.js 0.12.7 , and they are corrected in 0.12.10. So the latest 0.12.14 node.js version is our first choice.

If 0.12.14 node.js may not work with appium 1.4.8 , we can also consider any version between 0.12.10 and 0.12.14.

@benxu: I don’t think you will run into any issue using Appium v1.4.8 with node v0.12.14.
The build file mentions the minimum supported version of node is 0.12.7. So you cannot install appium on the node which is less than 0.12.7.
So I suggest you to give a try.

1 Like

thanks a lot , we are switch to node.js 0.12.14 and testing now. Hopefully, there is no issue.

1 Like