Can not run automation script on real iPhone device (iOS13)

Hi,

I updated Xcode to 11 from 10.3, appium to 1.15.0 from 1.14.2, real device iPhone X iOS to 13.1.1 from 12.3.1 and appium-xcuitest-driver (3.0.0) after that setup manual the WebDriverAgent(2.0.0) from new location.(/Users/username/node_modules/appium/node_modules/appium-webdriveragent).

The problem that I have is Xcode does not install WebdriverAgentRunner on the device although the build is successful in Xcode and when I want to run the tests I receive the error:
[debug] [W3C] 2019-09-28 01:35:01.922 xcodebuild[9444:68373] Error Domain=NSCocoaErrorDomain Code=260 “The file “WebDriverAgentRunner-Runner.app” couldn’t be opened because there is no such file.” UserInfo={NSFilePath=/Users/cristianmuresan/Library/Developer/Xcode/DerivedData/WebDriverAgent-ciegwgvxzxdrqthilmrmczmqvrgu/Build/Products/Debug-iphoneos/WebDriverAgentRunner-Runner.app, NSUnderlyingError=0x7fe03d69af50 {Error Domain=NSPOSIXErrorDomain Code=2 “No such file or directory”}}
[debug] [W3C] Testing failed:
[debug] [W3C] Signing for “WebDriverAgentRunner” requires a development team. Select a development team in the Signing & Capabilities editor.
[debug] [W3C] WebDriverAgentRunner-Runner.app encountered an error (Failed to install or launch the test runner. (Underlying error: The file “WebDriverAgentRunner-Runner.app” couldn’t be opened because there is no such file. The file doesn’t exist. (Underlying error: The operation couldn’t be completed. No such file or directory)))
[debug] [W3C] ** TEST EXECUTE FAILED **
[debug] [W3C] Testing started on ‘iPhone X’. Make sure you follow the tutorial at https://github.com/appium/appium-xcuitest-driver/blob/master/docs/real-device-config.md. Try to remove the WebDriverAgentRunner application from the device if it is installed and reboot the device.

In the previous configuration versions everything was perfect.
Can anyone help me with some tips about the issue?

1 Like

Hello Cristian
I have faced the same issue
So after doing same setup you did i tried to run
xcodebuild -project WebDriverAgent.xcodeproj -scheme WebDriverAgentRunner -destination 'id=myudid' clean build test

It was successful and installed the WebDriverAgentRunner to my phone
Then i opened this app - it gave ‘Untrusted app’ error so i accepted all apps from this developer in General -> Device Management -> - Trust

After it was done - i run tests and it worked

Also please note that you need to use the following for it to work in Appium:
Step 1 - npm uninstall -g appium && npm install -g [email protected]
Step 2 - Open appium-desktop and Modify Port to 4724
Step 3 - Open the terminal and type “appium” without the quotes. The appium through the terminal will be started. You will now be able to use the terminal appium from the appium-desktop.
Step 4 - In appium-desktop you should click on Start Server V1.13.0