Cannot click a xamarin forms ui element on Windows

Hello all, I’m testing a Xamarin forms application and need to click a custom ui element.
I’m able to locate it using this line:
var remembercheck = session.FindElementByAccessibilityId(TestConstants.StoreCredentialsCheckBox);

But unable to click it;
this command seems to run but nothing actually happens.

I also tried extracting the “ClickablePoint” for this element and click it (using x and y)
Actions action = new Actions(session);
action.MoveByOffset(Convert.ToInt32(clickablePt[0]), Convert.ToInt32(clickablePt[1])).Click().Perform();

But got this exception:
OpenQA.Selenium.WebDriverException: ‘Currently only pen and touch pointer input source types are supported’

I tried the using TouchAction with Press or Tap but failed miserably…with this exception: OpenQA.Selenium.WebDriverException: ‘Missing Command Parameter: element’

What am I doing wrong?
Appreciate your help
Daphna contains several examples of W3C actions supported by WAD.Also could be useful

Thanks for the reference - it was very helpful!
I managed to use the PointerInputDevice to tap the coordinates.

Many Thanks,