Cannot Connect to Simple Apcelerator Titanium HelloWorld Android App

I have had success connecting to Xamarin App and a Native React App (both on Android and iOS). However, we are considering moving to an Appcelerator Titanium framework for our Mobile apps and I cannot even connect to the simple HelloWorld app on Android.

Here are my base capabilities:
“platformName”: “Android”,
“platformVersion”: “7.1.1”,
“deviceName”: “Android device”,
“app”: “/Users/awaldorf/Downloads/app-unsigned.apk”,
“noReset”: true

I’ve tried setting the appPackage and appActivity but neither of those have worked for both the sample app and our company’s app.

I have an unsigned app that I can send for someone to look at. I would really like to use Appium to automate our Mobile Apps but if I cannot even connect, I will need to seek out another tool.


Andrea Waldorf
[email protected]

error pls. show us your error.

The app under test flashes twice and then appears to hang. I then see this error:

An unknown server-side error occurred while processing the command. Original error: Cannot start the 'com.smartsense.ti' application. Visit for troubleshooting. Original error: 'com.smartsense.ti.TestappcActivity' or '' never started. Visit for troubleshooting
and the app (just a simple hello world app) dies.

Tried setting appActivity to ‘com.smartsense.ti.TestappcActivity’ but that didn’t help. Also, not sure where it got the second activity from.