Cannot install .ipa file


I am working with ios version 10 and xcode 8.

When I am using appium to install the .ipa file on my phone I got an error of:

[MJSONWP] Encountered internal error running command: Error: Installing /var/folders/38/_j5rw9g93tn2mk_ypg0b12gc0000gn/T/2016815-20850-vgqq3k/Payload/ failed
at /Applications/
at ChildProcess.exithandler (child_process.js:193:7)
at emitTwo (events.js:100:13)
at ChildProcess.emit (events.js:185:7)
at maybeClose (internal/child_process.js:850:16)
at Socket. (internal/child_process.js:323:11)
at emitOne (events.js:90:13)
at Socket.emit (events.js:182:7)
at Pipe._onclose (net.js:475:12)

Any idea how to solve this?


I just updated the iTunes to 1.5 and I have same error (but not update xcode). Meyby try this

Let know if it worked

Thanks for your reply
I just performed the mentioned solution and now I have a different error:

[Xcode] Could not find Automation.tracetemplate in any of the followinglocations /Applications/,/Applications/

Any idea?

Run Appium doctor, maybe something suggests

Appium doctor did not suggest anything.
The thing I noticed is that if I run appium server version 1.6.0 beta then the error is:
Encountered internal error running command: Error: Command ā€˜/bin/bash Scripts/ -dā€™ exited with code 1

What this error suggests?