Cannot Setup Python Appium Test for AWS Device Farm

I’m trying to build an Appium Python test for AWS Device Farm on Ubuntu 15.10. I was following the instructions from Working with Appium Python for Android Applications and AWS Device Farm

But I always get the following error when I use

$ pip wheel -r requirements.txt

Could not find a version that satisfies the requirement package_name (from -r requirements.txt (line 2))
Cleaning up…
No distributions matching the version for package_name (from -r requirements.txt (line 2))
Storing debug log for failure in /home/username/.pip/pip.log

I install some packages -with big efforts- but I get same error for
another (mostly next) package. Also some packages -like PAM- are already
installed but it doesn’t change anything, still same issue.

Also when I use the following command, it says that requirement already satisfied for each package.
$ sudo pip install -r requirements.txt

What should I do? How should I handle this situation?
Thank you in advance.

Honest answer: I would post this question on the AWS discussion board:

Maybe there is someone on this board who has seen this problem (which is not an Appium problem) but I think you’ll be much more likely to get a good answer over there.

Good luck!

Thank you for reply. Actually I solved the problem after I posted this issue. Amazon just updated their documents. But now I have “no module” problem on cv2. Just working on it. And I don’t why but when I try to post on the forum that you linked, it says that my account is not ready to post new topic. I’ll try to solve it too. Thank you.

Check this video series to setup and run your Appium Python test cases in AWS Device Farm: