Can't connect Appium inspector to iOS Simulator (65 xcodebuild error message)

Hello. I’m testing a React native app on iOS and Android OS. I’m running my app on iOS Simulator and and use Appium 1.22.3-4 server with Appium inspector to inspect elements. Everything worked fine for a long period of time, but once I faced an issue while connecting appium inspector to iOS Simulator “Unable to launch WebDriverAgent because of xcodebuild failure: xcodebuild failed with code 65 xcodebuild error message”
I can build an app on simulator, but if I’m not mistaken, previously there was a WebDriverAgent installed with it. And moreover, I found, that I can’t run Appium Inspector even with clear simulator. Here are the appium logs.appium-server-logs without xcode.txt (27.4 KB)
I see, that there is a problem, while connecting to Please, help me to solve this issue, it really blocks my work!

Couple of things from your log:

[warn] e[35m[Appium]e[39m DeprecationWarning: ‘automationName’ capability was not provided. Future versions of Appium will require ‘automationName’ capability to be set for iOS sessions.

It’s always a good idea to include capability as such:

automationName: XCUITest

[debug] e[35m[BaseDriver]e[39m “appium:platformVersion”: “16.1”
[info] e[35m[Appium]e[39m Welcome to Appium v1.22.3

I would not use iOS 16.1 with Appium 1.22.3. If you need to test that, you should move to Appium 2.

[info] e[35m[XCUITest]e[39m The desired capabilities include neither an app nor a bundleId. WebDriverAgent will be started without the default app

I’ve found that Appium works a whole lot better when you provide the app capability. YMMV.

app: <path to your .app file>

[debug] e[35m[BaseDriver]e[39m “appium:udid”: "F39CFF57-2C98-4DDA-AB54-3C050960FC3

Don’t need to provide udid for Simulator.

So to summarize, I think that your capabilities are incomplete in some ways, and that you have capabilities that don’t make sense, plus you are trying to test an iOS version that in my experience doesn’t work in Appium 1.x.

Here is a tutorial on how capabilities work, and which ones you need:

Here is a tutorial on Appium 2:

Good luck!

Thank you! The problem is solved! It turns out, that appium 1.* doesn’t support xcode 14+. So, I installed Appium 2.0 with “npm install -g [email protected]”+ drivers and it solved my problem.


Heyy “npm install -g [email protected]”+ drivers, what did you mean “+ drivers” ? What do i need to download? Can you tell me ? appium%20driver%20install%20uiautomator2

run this:

appium driver install xcuitest
appium driver install uiautomator2
1 Like