Can't open Appium server

Fellow users,
I have an issue with my software, it’s a bot I use to control a Nox Android emulator.
I’ve been running it no problem for months, now when I launch it I get this error:
Unhandled exception. System.AggregateException: One or more errors occurred. (The local appium server has not been started. The given Node.js executable: C:\Program Files\nodejs\node.exe Arguments: “C:\Users\A2\AppData\Roaming\npm\node_modules\appium\build\lib\main.js” --port “50167” --address “”.
I have the same exact software on other PCs and it works good (also on this one was working good). I’ve tried to install it on other PCs as well and I get the same error. This is the code I use to open the server:
var _appiumLocalService = new AppiumServiceBuilder()
.WithEnvironment(new Dictionary<string, string>()
{ “ANDROID_HOME”, Settings.SdkPath },
{ “JAVA_HOME”, “C:\Program Files\Java\jdk-” }


I’ve checked the paths and they should be good (same as other PCs that are working). I’ve tried to unistall and reinstall everything, nothing changes.
Can you please help me?