Chrome not reachable when switching to WEBVIEW in hybrid app

Had Appium working with an older 1.4.x version a few months back but hadn’t used it in a few months and went to upgrade to newer versions. It has alas not worked since.

The appium console/log is attached below as appium_chromedriver_crash.log (was unable to paste it as some of the entries seem to be categorised as links and new users only have a limit of 4 links per post or something like that). I’m running tests via robotframework-appiumlibrary. The tests launch, connect to the (native) app and things go ok until I try to switch context to the webview and then it all breaks down.

I’ve had same or similar problems with both Appium 1.5.3 and 1.6.3 combined with Chromedrivers 2.14 through to 2.28 inclusive. Mostly the error is “chrome not reachable” but occasionally there’s a “device not online” or “no such session” error - error depends on Chromedriver version in use. With recent versions (> 2.25) it’s “chrome not reachable”.

I’m running on Fedora 23 x64 Linux and trying to test a xwalk hybrid app on a physical device (a 4.4.2-powered Android STB)

I’ve read many pages regarding this error but I’ve just run out of options - I can’t see anything relevant to my circumstances. I don’t know what to do to get Appium running again. Relatively new to Appium so some help would be really appreciated.

appium_chromedriver_crash.log (29.2 KB)

I decided to try this in Windows 7 (32-bit) also and, after getting everything set-up, I ended up with the same chromedriver message (chrome not reachable) when I try to switch context.

Upon finally finding the correct issue page, it would seem that my issues are down to our app being built using crosswalk/xwalk. Chromedriver (and therefor Appium) seem to have a problem with xwalk webviews. Tried the patches but did not work for me. Perhaps this might save some other poor soul wasting a bunch of time trying to find the needle in the haystack though.

See my posts here