Chrome welcome window on Android 13 emulator

Hi Team,

While running Android-13 emulator with Test Suite we are getting Chrome’s welcome window.
I did tried with various Appium capabilities mentioned below, but the results are same.
Any help would be highly appreciated.
I already went through older posts on the community forum and stackoverflow none of them helped so far.

Looking forward to a positive response from the community.
Capabilities I have tried so far:

“appPackage”: “”,
“appActivity”: “”,
“intentCategory”: “android.intent.category.LAUNCHER”,
“intentAction”: “android.intent.action.MAIN”,

1 Like

@mykola-mokhnach , curious now, what does the disable-fre flag mean, as in what does fre stand for?

Thanks @mykola-mokhnach for the response.
But sadly the disabling welcome screen via ChromeOption didn’t help either.
Welcome screen is still visible.

The capability in use are:
“appPackage”: “”,
“appActivity”: “”,
“intentCategory”: “android.intent.category.LAUNCHER”,
“intentAction”: “android.intent.action.MAIN”,
“chromeOptions”: {
“args”: ["–disable-fre"]

I did tried the capability mentioned by you at:

But still unable to resolve it.

Any suggestions from your side will be highly appreciated.

Many Thanks
Ganesh Sharma

Such behaviour is expected. chrome options are applied to chromedriver, although no chromedriver is used according to the above capabilities. Read

1 Like

Hi @mykola-mokhnach

I did tried to use the capabilities mentioned above, but the results are still negative.
Any suggestions from your end will be very helpful.

Capabilities with which I have played around is below:

            "appPackage": "",
            "appActivity": "",
            "chromeOptions": {
                "args": ["--disable-fre"]
            "chromedriverUseSystemExecutable": False,
            "chrome_options.chromedriver_executable": '/root/lambda/shared-tools/volume/drivers/chromedriver/101.0',
            #"chromedriverChromeMappingFile": "/root/lambda/shared-tools/volume/appium/appium-1.22.3/node_modules/appium-chromedriver/config/mapping.json",
            #"chromedriverExecutableDir": "/root/lambda/shared-tools/volume/drivers/chromedriver",
            #"chromedriverExecutable": "/root/lambda/shared-tools/volume/drivers/chromedriver/101.0",
            "intentCategory": "android.intent.category.LAUNCHER",
            "intentAction": "android.intent.action.MAIN",

if an option has a typo or is in the wrong place in the structure, the appium logs will “sometimes” tell you near the top that it was ignored, i assume you read the log