Click command returns successful but the button not being clicked

Hello ,

Some issue with the button , it’s not perform the click operation although no error being thrown.

[HTTP] --> POST /wd/hub/session/6fca5a4f-0d0d-4503-8ef6-8c1952e428ac/element/28/click {"id":"28"}
[debug] [MJSONWP] Calling with args: ["28","6fca5a4f-0d0d-4503-8ef6-8c1952e428ac"]
[debug] [AndroidBootstrap] Sending command to android: {"cmd":"action","action":"element:click","params":{"elementId":"28"}}
[debug] [AndroidBootstrap] [BOOTSTRAP LOG] [debug] Got data from client: {"cmd":"action","action":"element:click","params":{"elementId":"28"}}
[debug] [AndroidBootstrap] [BOOTSTRAP LOG] [debug] Got command of type ACTION
[debug] [AndroidBootstrap] [BOOTSTRAP LOG] [debug] Got command action: click
[debug] [AndroidBootstrap] Received command result from bootstrap
[debug] [MJSONWP] Responding to client with result: true
[HTTP] <-- POST /wd/hub/session/6fca5a4f-0d0d-4503-8ef6-8c1952e428ac/element/28/click 200 3117 ms - 76

if I add Thread.sleep before the ‘click’ , it works.

Any idea what goes wrong here ?

Itried to use explicit wait in order to locate the button , but still no click…

guys , any one ?

the behavior is very odd :persevere::sob:

Hi! Seems, I have same issue. How you solved this issue?

I am QA and trying integrate the Appium into my pet-project in the first time, I trying to click on the Next button programmatically using appium library. This button should brings me to the next screen, but nothing happens. Please, take a look at the code, will you have any ideas about why it doesn’t work, Thanks)
Note: I have native app for AndroidTV devices. I installed him to Android_TV_720p_API_28 emulator.

My code: myCode.txt (1.9 KB)
Appium-server logs: appium-server-logs.txt (33.7 KB)
pom file: pom.txt (1.3 KB)

I discussed with familiar developer, and he said that Next button is located in the different activity named AppConfiguratorActivity.
So, when I switch to this activity (AppConfiguratorActivity) and tried click on the Next button, I receive error: error_appium-server-logs.txt (30.0 KB)
newCode(when I switch to AppConfiguratorActivity): newCode.txt (2.2 KB)