Connecting to selenium hub giving Request failed with status code 404 error

I’m trying to connect my appium node to selenium hub

Step 1 i start the server for the hub and works fine
java -jar selenium-server-4.17.0.jar hub
Step 2 I start the appium server and get the error
appium server --nodeconfig C:\path\to\node1.json --base-path=/wd/hub

The error:
[Appium] An attempt to register with the grid was unsuccessful: Request failed with status code 404
[Appium] Hub down or not responding: Request failed with status code 404

Config File:
“browserName”: “Android”,
“maxInstances”: 1,
“automationName”: “UiAutomator2”,
“deviceName”: “emulator-5554”
“proxy”: “org.openqa.grid.selenium.proxy.DefaultRemoteProxy”,
“maxSession”: 2,
“host” : “localhost”,
“port”: 4723,
“register”: true,
“registerCycle”: 5000,
“hubPort”: 4444,
“hubHost”: “localhost”,
“nodeStatusCheckTimeout”: 5000

Any help will be appreciated

Have you read the instructions on how to do this?

From your description you are starting ‘hub’ first, which should be last.
Then you start appium server, which should be first.
You never start the nodes, which should be second.

It seems like a closer reading of the documentation would get you up and running.

I tried that and tried it in the same order as listed, but i still get this error where its failing to connect to the appium server i believe.
Error checking service status http://localhost:4723/status. HTTP/1.1 header parser received no bytes
03:05:46.202 ERROR [NodeServer$1.lambda$start$1] - Node is not alive: http://MYIP:5565 is DOWN

I’ve tried the configuration format listed in the documentation as well but still getting this error any help would be appreciated.
This is all running on the same machine.

Looks like this was a bug, downgraded to version 4.13.0 for the jar file and its able to work now.

1 Like