Could not start Appium server. It's showing [Error Starting appium server: listen EADDRINUSE 0.0.0.0:4723]

I am using Appium version V1.15.0 and have already start the server successfully with the default Host: 0.0.0.0 and Port: 4723

But now when i try to start the server it shows me this error “Error Starting Appium server: listen EADDRINUSE 0.0.0.0:4723”

I have tried to solve this issue by changing the port but could not find any solution.

Suggest me if you guys have any better solution.

The old instance of Appium server is still running. You’ll need to stop that instance if you want to start a new one. Methods for stopping the Appium server vary by operating system (Windows, Mac OS X, Linux), but reboot will work for any of them.

A web search would also help with this query: “stop process <operating system>”. Here is one for Mac OS X:

https://duckduckgo.com/?q=stop+process+os+x&ia=web

1 Like

Thanks for your answer. But it’s showing the same problem even after stop the instance. I am using Appium desktop in Windows machine. And ended the previous process from Task manager. So i am pretty sure that ending the previous process is not going to help me. Do you have any other solution to share?

So finally, I have found the solution. After restarting my computer, i could successfully run the Appium server.
If anyone face the same problem. Please follow below things:

  1. Check if the port is listening to any other services.
    Open command prompt: Type netstat -a -b

  2. Either kill that service or try with different port.

  3. If both not working then restart your machine.

This way i have solved this problem.

Thanks wreed. I have already solved this problem by restarting the pc.

1 Like

The following solution on windows worked for me
C:\Users\username> taskkill /F /IM node.exe
SUCCESS: The process “node.exe” with PID 13992 has been terminated.