"Did not get session redirect from Chromedriver" for Android Browser

So I’m getting the chromedriver equivalent of RROD: “Did not get session redirect from Chromedriver” for the native Android Browser and I’ve tried everything.

  • I’ve tried chromedriver versions 2.0, 2.2, 2.3, 2.9, 2.10, 2.11, and even 2.12.
  • I’ve tried real devices and emulators (on Android 4.4 )
  • I don’t think it’s chromedriver because if I switch to use Chrome it works fine.
  • The session is created, it’s just not redirected.
  • The device I’m trying it on is a non-rooted Samsung Galaxy S3


On real device, i think you can run the tests using appium on Chrome only.
But it should work on the Emulator fine i used Android Browser on the emulator with the 4.2.2 version without any problems.


Hey there:
I’m not sure if I’m following here.

I’m running into this problem also. Details:

  • Appium 1.4.11
  • ChromeDrivers tried: appium-chromedriver 2.7.4; chromedriver 2.17.340128 (using specific executable)
    *Genymotion 4.4.4 and 5.0 nexus 7/10 devices - webviews show in available_contexts just fine
    *Nexus 10 4.4.3 - webviews do not show in available_context command.
    *Latest Versions of Chrome on both Device and Mac Desktop Updated.
    *Increasing the autoWebviewTimeout to 30 seconds (30,000 ms).

I’m checking with our developers if setWebContentsDebuggingEnabled=True. I’m assuming so since this works in genymotion.

Not sure if I"m missing something.
My overall problem is that webview contexts are not shown on my personal android device but are shown fine if I use Genymotion.

Gist of the appium arc session in which we only see the NATIVE_APP context is here

any help welcome


This assumption was incorrect. SetWebContentsDebuggingEnabled was not set to true.