Does 'autoLaunch' capability works for iOS?

Even though the capability ‘autoLaunch’ has set to ‘false’ , the app is getting launched during the creation of the appium driver.

The capability works fine with Android but seems not working with iOS.

Please guide me here.


I want to install and not launch the app by default. I will be using driver.launchApp() in the next step to launch the application.

Hi all,

there seems to be no answer to this specific issue.

We are experiencing same on iOS. I tried it with following capabilities with no luck, app is getting launched anyway:

[Appium] Appium v1.14.2 creating new XCUITestDriver (v2.116.3) session
[Appium] Capabilities:
[Appium]   autoLaunch: false
[Appium]   platformName: ios
[Appium]   printPageSourceOnFindFailure: true
[Appium]   app: path.ipa
[Appium]   autoAcceptAlerts: true
[Appium]   automationName: XCUITest
[Appium]   bundleId:
[Appium]   deviceName: 00008020-001E49A10191002E
[Appium]   newCommandTimeout: 30000
[Appium]   noReset: true
[Appium]   platformVersion: 12.1.4
[Appium]   udid: 00008020-001E49A10191002E

This was a bug, which should be fixed in appium@beta

Hi, I tried to it with: Appium v1.16.0-beta.1 and it still does not work for me

Based on changes in this commit:

I assume that I shouldn’t provide app nor bundleId capabilities and it wouldn’t try to install/launch the app?
Or autoLaunch : false is still required?

Anyway, there seems to be an issue with installing the app on latest beta: