Does not recognize objects using UIAutomatorView


In our mobile application, we have a window which appears on left menu. We have a current time field on same.
We are not able to identify objects in those screens using UIAutomatorView.

Please suggest a solution for same, as this is showstopper for our mobile automation.
Below is the screenshots of error faced :

Error obtaining UI hierarchy
Reason :
Error while obtaining UI hierarchy XML file : Remote object doesn’t exist!

What worked for me:

stop appium
open an emulator device
go into settings > developer options > Enable view attribute inspection
open a shell on the computer, cmd or terminal depending on your OS
enter the following commands:
adb shell
cd /data
cd /local
chmod 777 tmp

start uiautomatorviewer
take an xml screenshot

“su chmod 777 /data/local/tmp” didnt work for me so I drilled down and it worked. I assume that you have to do this in an emulator and not a physical device unless the device is rooted. ¯_(ツ)_/¯

Lotsa Luck!