Edit saved session not saving settings

I have been using appium to control a remote machine, (macbook to iOS) quite happily, but when setting up a local server, having some pain with basic things not working. I am wanting to just use inspector to get a new local server set up.

  1. I started my local server

  2. I typed in my connection capabilities, hit save-as

  3. hit connect, server promptly closes
    So how do I find any server log files? I find this kind of silently just closing the process not great.

  4. I discover the cause is that I am trying to connect to an “Android”, but the saved capablities set still has “iOS” in the platformName parameter - all because the “save JSON” button actually does nothing at all. THe last capabilities I carefully added have been all thrown away.

  5. I hand type them all in again, correctly, and get a bit further, and get some useful error message now. But 2 hours later the save button is still not actually working.
    I have 3 capability sets, the iOS ones for remote server connect work fine.

I’m missing something basic here, any clues?

Okay worked it out

  1. select a profile
  2. click on the “desired capabilities” tab - (it’s counter intuitive for anyone who is living in a right-to-left reading order internationalization convention country, but just go leftwards)
  3. edit fields using mickey-mouse one at a time properties
  4. save

You cannot save any edits made in the JSON window, it’s just the way this UI was designed as was probably intended to be used. The save icon in the GUI is non functional UI framework candy.