Emulator with IOS9 Crashes on Appium 1.4.13

Hi all,

I have encountered a major issue running an IOS application on Emulator which runs IOS9.

Appium Server Works Fine but when pressing Inspector the emulator is crashed with Error “Instruments Crashed on startup”

I followed several threads which I found regarding similar issue, there was no concrete answer.
some of them:
Appium 1.3.1 inspector doesn’t support iOS 8
error: Failed to start an Appium session, err was: Error: Instruments crashed on startup
this thread is few weeks ago
[iOS]Instruments crashed on startup

First, There is no option for Platform Version 9.0 in Gui(I had to change it manually to 9.0 instead of 8.4).
From what I understood version 1.4.13 should support IOS 9.1 so it looks weird to me.

Second, All Settings are set as expected, App path is configured(Tried both with .Ipa and .APP)
IP, xCode is configured, names and the rest.

here is the log from the server:

Thanks a lot,

can you follow this post: Has anyone been able to use ios simulator 9.1 with Appium 1.4.13??
I think the problem is appium 1.4.13 is that it is shipped with instrument-without-delay enabled. But this option won’t work with xcode 7 anymore so you have to manually disable it by adding --native-instruments-lib option
I have tried it and it works for me

Hi @tbao,

I’ve tried what you told me, however i’m still getting the same error + the emulator entered into loop mode.

I found this thread,
Issues with Simulators on Appium 1.4.13


Could you try running authorize-ios.js inside appium bin folder m if the issue is still there?

This issue got resolved for me. I will explain the steps which I have done.
Go to Xcode ->Click Open Developer Tools-> Click Instruments->In
top of the Instruments tab you can find Choose a profiling
template(Choose your iPhone device)->Select Automation->Click
Choose button->Click the Play button.

Go to Appium and start the server.

Now your app get installed successfully in device.

@TamirS, To inspect in appium version 1.4.13, We need to include below steps also.

Go to Advanced settings in iOS settings. Tick " Use Native Instruments Library".

1 Like

Sounds good, I’m not next to my laptop at the moment , I will get back to you if it works.

cheers :smile:

1 Like

works perfect!
Thanks you

1 Like