Error: Cannot find module 'source-map'

Hello everyone, I need help from you guys.

this is the first time I installed Appium on my PC and I already installed nodeJs.

node version: v16.13.0
npm version: 8.1.0

but when i tried to install appium on command prompt like this:
C:\Users\jimmy>npm install -g [email protected]

the result is like this:
changed 28 packages, and audited 29 packages in 5s

    19 vulnerabilities (12 moderate, 5 high, 2 critical)

    To address all issues, run:
      npm audit fix

    Run `npm audit` for details.

and when i tried to check appium version, command prompt show this error:
throw err;

Error: Cannot find module 'source-map'
Require stack:
- C:\Users\jimmy\AppData\Roaming\npm\node_modules\appium\node_modules\source-map-support\source-map-support.js
- C:\Users\jimmy\AppData\Roaming\npm\node_modules\appium\build\lib\main.js
←[90m    at Function.Module._resolveFilename (node:internal/modules/cjs/loader:933:15)←[39m
←[90m    at Function.Module._load (node:internal/modules/cjs/loader:778:27)←[39m
←[90m    at Module.require (node:internal/modules/cjs/loader:1005:19)←[39m
←[90m    at require (node:internal/modules/cjs/helpers:102:18)←[39m
    at Object.<anonymous> (C:\Users\jimmy\AppData\Roaming\npm\node_modules\←[4mappium←[24m\node_modules\←[4msource-map-support←[24m\source-map-support.js:1:25)
←[90m    at Module._compile (node:internal/modules/cjs/loader:1101:14)←[39m
←[90m    at Object.Module._extensions..js (node:internal/modules/cjs/loader:1153:10)←[39m
←[90m    at Module.load (node:internal/modules/cjs/loader:981:32)←[39m
←[90m    at Function.Module._load (node:internal/modules/cjs/loader:822:12)←[39m
←[90m    at Module.require (node:internal/modules/cjs/loader:1005:19)←[39m {
  code: ←[32m'MODULE_NOT_FOUND'←[39m,
  requireStack: [

what should i do ?

why 1.8.1 version which is May 2018 ?

Hi, I use this version for training automation tools and my mentor suggested using that version

use better latest. old version no one going to fix.

or! use all other software versions from 2018. e.g. your node version is 2021-10-26.

PS and phone’s version also from 2018… looks not nice…

ok, thanks for your advice