Error executing mobile command for deep link on Android


I’m trying to launch a deep link using the mobile command ‘mobile: deepLink’. This works for me on one device (Android 9) but does not work on others (lower Android versions–not sure if this is relevant).

I’m using Appium v1.15.1 in Katalon Studio.

My code:

AndroidDriver<?> driver = MobileDriverFactory.getDriver()
Map<String, Object> params = new HashMap<>()
params.put("url", "<MyDeepLinkURL>")
params.put("package", "<MyAppPackage>")

driver.executeScript("mobile: deepLink", params)

Error message:
org.openqa.selenium.WebDriverException: An unknown server-side error occurred while processing the command. Original error: Error attempting to start URI. Original error: Error: Error executing adbExec. Original error: 'Command '/Users/<user>/.katalon/tools/android_sdk/platform-tools/adb -P 5037 -s f2979388 shell am start -W -a android.intent.action.VIEW -d <url> <package>' timed out after 10000ms'. Try to increase the 10000ms adb execution timeout represented by 'adbExecTimeout' capability

I’ve tried increasing the adbExecTimeout as advised but still receive the same error. Not sure why this works on one device but not another.

Any suggestions or further information is appreciated.

what happens if the same command is executed manually from the terminal?